2

I'm running VirtualBox 5.0.18 with Ubuntu 16.04. I've installed VirtualBox Guest Additions and DKMS, which enabled the automatic screen resolution in my VB. This worked fine for several months until today. I accidentally changed the screen resolution and the automatic screen resolution stopped working. Installing Guest Additions and DKMS again didn't work. They are still installed and are up to date with the latest versions.

I've tried this command but it didn't work:

sudo dpkg-reconfigure virtualbox-guest-dkms

Is there a way to activate the automatic screen resolution again? Thanks.

  • Have you already checked the settings? This particular setting is under File > Preferences > Display > Maximum Guest Screen Size – wjandrea Jun 1 '16 at 5:19
  • the current option in Maximum Guest screen size is: Automatic. should i change it to something else? – user1845156 Jun 1 '16 at 5:34
  • That's what it should be. Another suggestion: have you tried reinstalling Guest Additions within the guest OS? – wjandrea Jun 1 '16 at 5:37
  • i've tried to but i've got the latest versions so the installation did nothing. should i try removing them and installing again? – user1845156 Jun 1 '16 at 5:39
  • 1
    i found the issue, in the 'view' tab, the option "auto-resize guest display" wasn't checked, checking it solved the issue and the automatic resolution now works again, i feel like such a noob. Thanks wjandrea for the help. – user1845156 Jun 4 '16 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.