I am using the latest Xubuntu x64 version as of this posting.. It's installed in dual boot with Windows 10.. the KB Backlight is working when I boot on Windows and from the bios.. The moment It enters the Xubuntu Startup screen the KB Backlight turns off and doesn't turn on.. Thanks in advance for the help..

Output of: ls /sys/class/leds/

  • check this answer askubuntu.com/a/644420/464430 Jun 1, 2016 at 3:48
  • Thanks @MohamedSlama for the quick response but that one's for Asus..
    – im.earl
    Jun 1, 2016 at 3:51
  • Isn't it just xset led 3 to turn it on, and xset -led 3 to turn it off?
    – Terrance
    Jun 1, 2016 at 5:27
  • Hi @Terrance, tried it but it does not work..
    – im.earl
    Jun 1, 2016 at 9:44

2 Answers 2


To enable the backlight:

echo 2 | sudo tee /sys/class/leds/toshiba::kbd_backlight/brightness 

The 2 at echo 2 | can be changed to a value between 0 - 3, with 3 being the brightest.

To disable the backlight, enter:

echo 0 | sudo tee /sys/class/leds/toshiba::kbd_backlight/brightness

reference this answer but changing asus to toshiba .


some people whom report this issue say disabling acpi solve the problem to disable acpi:

  1. open terminal
  2. edit /etc/default/grub
  3. append acpi = off to GRUB_CMDLINE_LINUX_DEFAULT
  4. update-grub
  5. if not working do these steps again and delete acpi = off

if none of these solution work may it's this bug

  • Nope.. Does not work.. eirol@--------:~$ echo 2 | sudo tee /sys/class/leds/toshiba::kbd_backlight/brightness [sudo] password for eirol: tee: '/sys/class/leds/toshiba::kbd_backlight/brightness': No such file or directory 2
    – im.earl
    Jun 1, 2016 at 9:37
  • eirol@-----:~$ ls /sys/class/leds/ input3::capslock input3::numlock input3::scrolllock phy0-led eirol@-----:~$
    – im.earl
    Jun 1, 2016 at 9:45
  • @EirolJohn i update my answer Jun 1, 2016 at 11:35

try with Fn+Z it worked in my toshiba

Reference found here https://forum.manjaro.org/t/toshiba-backlight-keyboard/25235

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.