10

I've been having some fairly major issues with Ubuntu graphics. Googling turns up many Launchpad bugs, many Stack Exchange articles and pages from other forums. But no one seems to be fixing this so I'm just going to post this in the hope someone can help/fix this issue. (Here's one from 9 days ago: Intel graphics and DisplayPort: *ERROR* failed to train DP, aborting and here's my Launchpad bug: https://bugs.launchpad.net/ubuntu/+bug/1574617)

I have a ThinkPad T450s with an Intel Integrated Broadwell GPU. I used to own an Ironlake T410. On both of these laptops, when upgrading to 16.04 from 15.10 I have begun encountering:

  • Major screen flickering and blanking
  • Decreased graphics performance (YouTube, HTML5 etc.)
  • Issues when connecting external monitors (monitors drop out, refuse to come out of sleep saying there is no connection but Xrandr has the monitor down as active and thinks it is piping data to it)
  • If you're lucky enough to get a connection, if you move your pointer across the monitors (extended display) you'll get an epileptic fit from the amount of blinking and flashing...

These are generally when plugged into the docking station and across any digital output (DP, DVI, HDMI...), VGA seems more stable but my monitors are all digital so I only get to 'trial' it when I plug into the meeting room projector... It is possible to get a connection to the monitor over digital ports, it's pretty random but generally it will stay working for a while then when your laptop goes to sleep, the monitor goes to sleep and then doesn't wake up: sometimes it does, most times it doesn't. Either way, it soon drops out as you drag something across...

These bugs are driving my crazy, I've tried the Intel drivers, updating the kernel modifying xorg.conf files - I'm pretty sure this is a bug but if I'm doing something really stupid I'd like to know as otherwise I'm really starting to lose faith in the 'open source bugs fixed ASAP' model that everyone is championing...

  • I understand that it's frustrating, but keep in mind that it's in your specific situation you are encountering problems with your Graphics. There doesn't appear to be a problem with all Ironlake & Intel Integrated Graphics (dual-monitor setup worked fine with mine), but the question you linked to mentions using a docking station to connect to the monitor. It would be an important detail to clarify if that's what you're using as well. Edit your question to explain your setup. Your specific combination of hardware - i.e laptop -> docking station? -> type of monitor? (VGA? HDMI? Displayport?) – pHeLiOn May 31 '16 at 23:43
  • All the above things will help narrow down where the problem might lie. Also, you mention upgrading from 15.10 to 16.04 with both your laptops. Do I understand correctly that it was all working fine before the upgrade? – pHeLiOn May 31 '16 at 23:44
  • 1
    And yes, on 15.10 both worked great - upgrade to 16.04 instant problems – CrabLab Jun 1 '16 at 8:20
  • 2
    Okay, so when connected through a docking station, there seem to be serious issues with a dual monitor setup. Someone who knows their stuff should hopefully be able to shed more light on the situation than I can. My suggestions are fairly untechnical & don't really get at the root of the problem - I'm curious as to whether a fresh installation of 16.04 experiences the same problems or whether the issue occurred during the upgrade. Do you have a bootable USB of either 16.04 or 14.04 to try out? Not really a solution, but something to try whilst waiting for an answer, maybe. – pHeLiOn Jun 1 '16 at 16:24
  • 1
    Have the same issues. – user14416 Jun 6 '16 at 10:15
3

I am also getting this issue with Intel integrated graphics on my Dell XPS 13 after upgrading to 16.04 LTS.

Let's see if we can fix this together. Can you copy-pasta the output of the following terminal commands:

sudo su
*password for super user*
lshw -c video

Tell me what you get and if it's similar to my trouble maybe my solution attempt will work for you.

UPDATE: I use Intel Integrated graphics for my machine so I think I have a solution. I will update by the end of the day, but it seems to be working fine with dual display at work. I did the following:

sudo su
*password for su*
apt-get install --reinstall xserver-xorg-video-intel
dpkg-reconfigure xserver-xorg
apt autoremove

UPDATE: The above stopped my screen from flickering until I opened google chrome, or chromium. I believe this may be related to gpu optimization in chrome and chromium. I will look into this more and clean up this update when I have narrowed the problem down.

Final UPDATE: I pushed a short bash file to my github page that definitively solves this problem for intel integrated graphics users. You can download it and run it from https://github.com/0xSteve/Ubuntu-16.04-LTS-Bug-Fixes-for-Dell-XPS-13

If my answer helped you please give me an up vote and help me make better posts in the future by commenting.

  • 1
    *-display description: VGA compatible controller product: Broadwell-U Integrated Graphics vendor: Intel Corporation physical id: 2 bus info: pci@0000:00:02.0 version: 09 width: 64 bits clock: 33MHz capabilities: msi pm vga_controller bus_master cap_list rom configuration: driver=i915 latency=0 resources: irq:44 memory:e0000000-e0ffffff memory:c0000000-dfffffff ioport:3000(size=64) memory:c0000-dffff – CrabLab Jun 7 '16 at 19:06
  • 1
    Tried reinstalling Xorg (and it worked...!) until I logged in and my profile upped the resolution and then the display dropped out again – CrabLab Jun 7 '16 at 19:06
  • 1
    Yes, I had this same error happen to me today! Then it came back after I con nected my second monitor. Do you use google chrome or chromium browser? Im writing something to my git to fix all this once and for all and will post the link soon. – mandragoras Jun 7 '16 at 19:51
  • 1
    Hmm, that didn't happen for me... I had to reinstall Xorg and restart to get my external monitors back. Google Chrome as Chromium's password manager broke (another launchpad bug...) – CrabLab Jun 8 '16 at 6:37
  • did the script i posted help? it solved my problem. – mandragoras Jun 8 '16 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.