3

The issue

I recently installed Ubuntu 16.04 on a windows machine. Everything seems to be working fine, except for the fact that wifi doesn't seem to be an option for connections

I still have access to other machines that I can use to transfer packages offline

What I've tried, that didn't work

googling away, I've found a post from someone saying that I need to use these commands:

rfkill list
rfkill unblock wlan0

and other commands, but then an error appeared saying Bogus unblock argument 'wlan0', which made sense because it wasn't listed in rfkill list

I then tried this, but the final progress bar didn't seem to proceed, as some users complained in the comments

So I then tried installing bcmwl-kernel-source manually, along with the other packages it needed. I did that and rebooted the machine several times, but I still don't see the wifi as an option

The last thing I tried was setting up a new connection using the "edit connections" button from the image above, and set it to what I could see from my other ubuntu machine over wifi, but I still don't see the option to connect through that anywhere.

outputs of requested commands

Output of lspci -nnk | grep 0280:

01:00 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

Output of sudo modprobe ul:

modprobe: ERROR: could not insert 'wl': Required key not available

--

Any help is greatly appreciated

  • Please edit your question to add the result of this command from the terminal: lspci -nnk | grep 0280 -A2 – chili555 May 31 '16 at 20:34
  • @chili555 01:00 Network controller [0280]: Broadcom Corporation numbersnumbers Kernel modules: bcma, wl – towc May 31 '16 at 20:37
  • check my previous answer may helping you askubuntu.com/a/773914/464430 – Mohamed Slama May 31 '16 at 20:42
  • @chili555 ok, properly updated. Currently reading this: askubuntu.com/questions/55868/… – towc May 31 '16 at 21:07
  • What is the result of the terminal command: sudo modprobe wl – chili555 May 31 '16 at 21:21
1
modprobe: ERROR: could not insert 'wl': Required key not available

This is the subject of a recent and still open bug in Ubuntu: https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1572659

It appears that the only solution so far is to enter the computer's BIOS and turn off Secure Boot.

To do so roam around the options after booting your windows machine in F12 mode, until you find a Secure Boot switch and turn it off. Then exit and boot Ubuntu normally

Secure Boot is a security standard developed by the PC industry to help make sure that your PC boots using only software that is trusted by the PC manufacturer

Reboot. Your wireless should now be working.

0

easy peasy.

  1. Disable Secure Boot.

  2. Connect this computer to Ethernet / an internet connection.

  3. go to "Additional Drivers" and install and enable all the options.

  4. profit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.