6

For some reason Ubuntu hides the cursor when I'm hovering my stylus above the pad. It works ok when you are in drawing area since it has its own cursor. But it's completely useless when you try to use the UI of the graphics program or the desktop itself. How do I force Ubuntu to keep the cursor visible?

EDIT: I've done some testing and it seems that it is 16.04 specific problem. On my other machine with 15.10 cursor does not hide. This is also not related to nVidia GPU driver or hardware. I have tried on yet another machine with 16.04 but with Intel GPU and cursor hides again.

EDIT2: Running

  gsettings set org.gnome.settings-daemon.plugins.cursor active true
  gsettings set org.gnome.settings-daemon.plugins.cursor active false

in terminal (after cursor gets invisible) causes tablet cursor to work as long as I don't move mouse. When I move mouse even a pixel then tablet cursor gets invisible. Sometimes it disappears randomly and I have to execute these two commands again.

  • I had the same problem. I installed Gnome Desktop and it worked in that environment. It's just a work around, not a solution. – Alexandre Campos Sep 15 '16 at 12:35
2

I've finally figured it out. The problem was that my mouse was connected via PS/2 port and my tablet was connected via USB. I've connected my mouse via USB and cursor disappeared permanently. But after system restart everything works perfectly fine. I can control my pointer using both mouse and tablet and nothing disappears anymore. Looks like Xorg can't handle input from PS/2 and USB at the same time.

But Ubuntu 15.10 had no problem with it. Machine with 15.10 on which I've done testing before is a laptop with touchpad connected internally via PS/2 and I was using exactly the same USB tablet. There were no problems on that machine.

1

in the your /etc/X11/xorg.conf in any of the Display, Screen, Monitor, Device sections you can specify the HW or SW cursor options to control how the display of the cursor is managed. Try either of these to prevent the cursor being hidden.

Option "HWcursor"

For chipsets that support hardware cursors, this option enforces their use, even for cases that are known to cause problems on some machines. Note that it is overridden by the "SWcursor" option. Hardware cursors effectively speeds all graphics operations as the job of ensuring that the cursor remains on top is now given to the hardware. It also reduces the effect of cursor flashing during graphics operations.

Option "SWcursor"

This disables use of the hardware cursor provided by the chip. Try this if the cursor seems to have problems.

  • My system does not use xorg.conf but I've generated one using nvidia-xconfig. After adding Option "SWcursor" to the Screen section a lot of glitches began to appear when I moved the cursor. Plus, tablet cursor was still invisible. – pvc Jun 6 '16 at 15:58
  • How about hwcursor ? – Amias Jun 6 '16 at 20:20
  • Then absolutely nothing happens. – pvc Jun 7 '16 at 9:16
  • hmm , this sounds like something in the drivers for the touchpad , i've not seen this elsewhere – Amias Jun 7 '16 at 12:33
  • No touchpad in my system. Both machines with 16.04 I've tested are regular desktop PCs. One with nVidia GPU has 2 displays attached. And tablet is using your typical usbhid driver. – pvc Jun 7 '16 at 13:05
1

I faced something similar which I worked through on the Ubuntu Forums at thread

Long story short after trying Amias answer, creating an empty /etc/X11/xorg.conf file seemed to do the trick though I am now getting system errors on start up.

0

I don't know if this is still a problem. I found a video on YouTube a while ago about this, and I had the same problem when I switched to Ubuntu 16.04 LTS. The solution oddly enough was to go into Gimp and under the input devices you have to change a setting. It worked for me. No error messages or anything. No cursor was visible when I set up my tablet but I could box select items, so input was being emulated just no cursor, and pen click behaved like right mouse click. I did the Gimp input devices change and my cursor appeared and pressure sensitivity began working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.