0

I can't download the snap packages.

OS: Ubuntu 16.04

enter image description here

  • That looks like a temporary store issue. Have you tried again? – Kyle May 31 '16 at 13:53
  • I have tried it for days. – JulianLai May 31 '16 at 13:54
0

Are you behind a proxy by any chance? There's a fix that makes snapd respect proxy settings. It's already merged but it is not released yet. It will likely show up in snapd 2.0.6

For now you can edit the systemd unit of snapd and add

EnvironmentFile=/etc/environment

And obviously ensure that your proxy settings are stored in /etc/environment.

  • I'm not using the proxy now. – JulianLai May 31 '16 at 14:07
  • 1
    I have solved the problem, just typed "snap login 'email' " – JulianLai May 31 '16 at 14:10
  • Please update your question with an answer so others can find it more easily – Amias May 31 '16 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.