1

I am working with a virtual machine. I can ping the other machine from my "Router" but not able to ping back from the "client"? Can anyone help me in this regards.

PING not working both ways

2

This looks like a firewall is locking the ping.

I supose you are using Ubuntu 12.04.

By default, ubuntu has no firewall configured, but you can try to stop it.

sudo ufw disable

You can try to stop iptables

sudo service iptables stop

It will stop the service. Try if you can conect now. To start it again.

sudo service iptables start

Or maybe can be a virtual machine issue. When I was making an own lab on virtual box from Windows, I couldnt ping from my virtual machines to windows. I didn't fix this issue.

Source: How do I turn off the firewall in Ubuntu 12.04?

  • I am using Ubuntu 12.04.5 LTS (GNU/Linux 4.2.8-1-pve x86_64). – Waqas Ahmad May 31 '16 at 8:35
0

You have to bridge your virtual network card with your real network card.! They must be in bridge mode for this to work.!

You can configure bridged networking for an existing virtual machine. To configure bridged networking for a new virtual machine, select Customize Hardware when you run the New Virtual Machine wizard. Procedure 1 Select the virtual machine and select VM > Settings. 2 On the Hardware tab, select Network Adapter. 3 Select Bridged: Connected directly to the physical network. 4 If you use the virtual machine on a laptop or other mobile device, select Replicate physical network connection state.

This setting causes the IP address to be renewed when you move from one wired or wireless network to another. 5

Click OK to save your changes.

  • I am using PuTTY to connect to the Virtual machines, can't do any of the things that u r saying. – Waqas Ahmad May 31 '16 at 8:52
  • Use teamviewer to do the work..!! – farmuel Angel May 31 '16 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.