This question already has an answer here:

I've recently installed Ubuntu 16.04 and I cannot get Nautilus to open. Clicking on the icon does nothing and I've already tried un-installing and reinstalling it and the error persists. So I have tried to to launch it from the terminal and these error messages are returned:

(nautilus:27014): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
(nautilus:27014): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
Could not register the application: Timeout was reached
(nautilus:27014): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(nautilus:27014): GLib-GObject-WARNING **: invalid (NULL) pointer instance
(nautilus:27014): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

I'm not certain if I should just scrap nautilus for some other file manager or perhaps there is a solution to this problem?

marked as duplicate by terdon Jun 16 '17 at 21:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did you upgrade or install freshly? – Jacob Vlijm May 31 '16 at 7:12
  • It was a fresh install. – pingwinZloty May 31 '16 at 7:14
  • did you try creating another dummy user to see if the same problem occurs? – Andrea Borga May 31 '16 at 7:16

You can try restart nautilus

$ killall nautilus
$ nautilus -q

then try launching it again

$ nautilus

It happens to me that sometimes something - not yet understood - doesn't start properly. The above recipe fixes it.

  • This works! The truth is I'm new to Ubuntu and linux in general. In fact, another issue that I was having is compatibility issues with two of my flash drives where one wouldn't mount because it's an exfat filesystem, and the other I was able to trace to not having nautilus opening up in the first place. But thank you for this neat trick and hopefully the developers patch this issue. It certainly looks like a software defect to me but you never know if someone out there came up with a patch for this issue! Thanks again Andrea! – pingwinZloty May 31 '16 at 7:21
  • @pingwinZloty If you have another issue, please do ask a new question on the main page. – Mark Kirby May 31 '16 at 9:10
  • yep, ask another question!:) Glad I could be of help. – Andrea Borga May 31 '16 at 15:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.