5

I've been getting screen tearing that is only present in Ubuntu (MATE 16.04).

Often when scrolling on pages, I get a horizontal line that tears through, and the same goes for games, particularly Minecraft (whenever I look around there is a horizontal tear)

It is extremely frustrating because the issue is not present in Windows.

I am using an i5-3570k with a NVIDIA GTX 670. Currently using the NVIDIA 361.42 proprietary drivers available through the driver options.

I tried the solution here by putting a configuration file in /usr/share/X11/xorg.conf.d as well as this solution to no avail.

1
  • 1
    Try opening "MATE Tweak" from the preferences menu. What is selected as your compositor? Try the other options one-by-one to see what works best May 31, 2016 at 0:09

1 Answer 1

2

I might be a little late here, but since you are using a NVIDIA graphics card the problem can be solved by editing nvidia-settings (make sure nvidia-settings is installed):

  • Open nvidia-settings (as root, via sudo).

  • Go to XServer Display Configuration.

  • Click on Advanced.

  • Enable Force full composition pipeline or Force composition pipeline (depends on what feels best for you).

  • Make sure to hit Save to x configuration file.

This solves almost all screen-tearing related problems with proprietary NVIDIA drivers.

3
  • 1
    There is no ' force full composition pipeline' or any other similar option in the UI. Jul 23, 2018 at 19:59
  • I do the 'force full composition pipeline' on Nvidea Settings app, but not change nothing. Aug 15, 2018 at 3:31
  • After switching GPUs, I also encountered tearing. This answer immediately helped.
    – Dunkelkoon
    May 16 at 21:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.