9

I have recently upgraded from Ubuntu 15.10 LTS to 16.04 LTS via the upgrade notification i have received.

The laptop boots up and i am shown the login screen with the 3 previously created accounts.

If i log in with the admin account in GUI mode, i am taken to a black screen. I can switch to a terminal and log in with the admin acccount, so the credentials are ok.

If i log in with any of the other 2 accounts i am taken to the normal desktop.

Any ideas as to why this is happening and how do i get the GUI mode back for my admin account?

I am new to ubuntu so i might not be aware of all the commands.

  • 1
    Can you log into the admin account with (1) a different desktop environment selected during login or (2) an empty user configuration of the current desktop environment (you can rename ~/.config to ~/.config.bak from the virtual terminal or something similar)? – David Foerster Feb 6 '17 at 19:03
  • @David Forester this almost worked... Had logged in to my Default XSession... But now desktop shows without sidebar 😫 I'm using Ubuntu 16.04 LTS – Robin Hood Mar 13 '18 at 14:54
  • @RobinHood: Could you please open a new question if you have a new or follow-up question? The comment section is not suitable or meant for new questions or extended discussion. You’re welcome to send me a comment with a notification to draw my attention to it. Thanks. – David Foerster Mar 13 '18 at 14:56
6

I had the exact same problem. I found the solution here:

sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade -y

Finally run sudo reboot, Ubuntu restarts, and then you can log in again normally.

| improve this answer | |
1

I had this same problem with Ubuntu 20.04 using the NVidia proprietary drivers (both 440 and 450) for my Geforce RTX 2070. The problem was with the experimental feature of fractional display scaling that I enabled in the Display configuration settings. Apparently, the NVidia drivers do not play well with these settings (yet) and a bug has been filed for it: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-440/+bug/1870758

There are several ways to remedy this:

  • Check your ~/.config/monitor.xml settings and change any value occurring between <Scale> tags back to 1. Then save and reboot. This didn't work for me though although I have seen others report success.
  • Reset the fractional scaling setting to off by executing
gsettings reset org.gnome.mutter experimental-features

Reboot and hopefully this will bring back your screen (like it did for me).

It's too bad fractional scaling through the GUI doesn't work well yet. I had written a basic xrandr script on 18.04 to get the scaling on my 2 displays with each a different resolution right, and that worked well, but I was happy to see there finally was GUI support for this feature in 20.04. Hopefully they manage to fix this soon.

| improve this answer | |
  • First of all thank you because this is a lifesaver. I know how frustrating displays can be with nvidia drivers on Ubuntu. I suppose the xrandr script you wrote won’t work on Ubuntu 20.04? – rivu Aug 4 at 11:40
  • Yes it does! But is specific for my monitor setup, so I can provide it to you as an example, but you need to adapt it to your situation. – Daniel Schreij Aug 5 at 12:05
  • Thanks, could you please share it? – rivu Aug 5 at 13:20
  • 1
    Sure, I created a gist for it with some instructions: gist.github.com/dschreij/148e958d032a61aa744b879e49a16d53 hopefully this helps! – Daniel Schreij Aug 6 at 7:55
  • This is lovely thank you! – rivu Aug 10 at 12:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.