4

I installed Unity3d on Ubuntu 14.04 LTS. It works, and I want to get started. So I make a C# script, and when I try to open it nothing happens. No error message, no anything. I just double click it or right click and select "open", and nothing happens. So I went to preferences, and I selected the gnome text editor, and when I double click it now, it opens up the script. So it is clearly a problem with MonoDevelop. When I try to open up MonoDevelop without using unity3d, just the application, nothing happens a well. Does anyone know what the problem is, and how to solve it?

Thank you.

7

As I don't have enough rep to comment on your question, I'll have to ask you this through the answer.

Did you try to open monodevelop through the bash (open a terminal then type monodevelop and press enter)

In case monodevelop is not installed, you might need to install it yourself

sudo apt-get install monodevelop
  • OK so I did that, and it said monodevelop was not installed, so I had to do sudo apt get-install... blah blah blah monodevelop. so I typed that in, and it installed it! Unfortunately, when I opened the script, t just went into the monodevelop home screen, instead of a project. But thank you, that worked! – Demandooda May 30 '16 at 16:43
  • Well, at least I'm glad I could help you to find out the cause. Regarding the inability to open the project, I'm not sure about how unity handles it, but normally it should be possible to create a correct file association in case it's broken, by saying that the program you want it to be used is "monodevelop %U" Where %U is being substituted by the file. (I'm a KDE user unfortunately) Also I'm not sure if by Unity you mean Unity3D or Ubuntu Unity as you're referring to C# scripts. – The19thFighter May 30 '16 at 21:39
  • Please try not to leave the answer ambiguous for other people having the same issue. Explain the steps more precisely. I couldn't get help from your answer. – Mina Michael May 31 '16 at 8:37
  • There is no way in not answering vaguely, if they aren't enough information in the question, and if you're unable to tell exactly which program is affected. In this case I didn't know it was about Unity3D and I thought he might have talked about Unity (nautilus or nemo). Also "doesn't start" requires more information (in this case by starting monodevelop using the bash). Normally I'd ask this in a comment, but need 50 rep. And afterwards he used the bash, half of the issue resolved itself by installing monodevelop first (as suggested by the console output). The other half is solved below. – The19thFighter May 31 '16 at 8:56
7

I was having the same issue.

The script for opening monodevelop needed a program called realpath that I didn't have, so;

sudo apt-get install realpath

Experts: there are alternative methods to installing realpath ;)

Also you might want to double-check that Unity3D has the correct path to monodevelop;

  • Open Unity3D, in the menus go to Edit > Preferences
  • Go to the 'External Tools` tab
  • Open the drop-down menu External Script Editor and select brwose (below)

Preferences Window

Depending on where you have monodevelop installed you should select the script named "monodevelop".

I had monodevelop installed with Unity3D.

Path Explanation

Find the monodevelop folder and select MonoDevelop/bin/monodevelop

  • install with yes flag?? sudo apt-get install monodevelop -y & then use /usr/bin/monodevelop – CrandellWS Nov 4 '16 at 5:00
  • External Script Editor Args won't show up anymore as of Unity 2017 (at least on Linux), with Monodevelop support being dropped. You can use a symlink script with a different name than "monodevelop" to make the args appear again but then you'll have other problems due to symlinking. The staff suggested me to use VS Code or Rider, unfortunately in Rider on Ubuntu the special keys are not working. And vanilla Monodevelop cannot connect to unity anyway. I guess I'll only be able to debug on VS Code. – hsandt Jun 22 '18 at 21:45
  • I didn't need realpath. See the monodevelop project for the instructions to install the repository so you can install it, install it, then follow instructions to configure Unity. – Michael Cole Aug 8 '18 at 3:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.