11

On my Ubuntu 16.04 laptop installation, Alt-Gr does not work. So I cannot type characters like {, }, ~, | etc. (doing this on my PC where everything works). I tried various suggestions from multiple Ubuntu wikis, forums, Ubuntu support site: Nothing works.

Most solutions are for older Ubuntu versions, a lot seems to be different on Ubuntu 16.04: There is no System Preferences (you can install the app manually, but there are no keyboard settings there), I don't find Keyboard Layout anywhere...

This is not a duplicate of Alt-Gr key is not working in Ubuntu 13.10, Ubuntu 16.04 is different!

Edit: Found the keyboard layout display, and it matches the keyboard (now). But Alt-Gr combinations don't work.

9
  • 3
    Possible duplicate of Alt-Gr key is not working in Ubuntu 13.10
    – MadMike
    May 30 '16 at 11:38
  • It's 16.04, there is no 'Region and Language' in Settings (which is called 'System Settings' now).
    – Rene
    May 30 '16 at 11:51
  • Ah! A fellow swiss ubuntu user! :-) I'm using Ubuntu (and other Linux distibutions) with swiss-german layout since some time. I'm pretty confused why your keyboard layout doesn't match. I'm using "Alt Gr" pretty often too. Can you explain in more detail what part of the swiss german layout isn't working right?
    – MadMike
    May 30 '16 at 12:02
  • Due to an article I found somewhere else, I just changed the keyboard type to 'generic, 105 keys, intl'. Now the keyboard layout displayed does match, but the keys don't. ; instead of ö ' instead of ä \ instead of $ Alt-Gr combinations don't work at all
    – Rene
    May 30 '16 at 12:09
  • 1
    The Keyboard Layout Setting is still there, @Rene. It's just called Text Entry now.
    – anonymous2
    May 30 '16 at 12:15
8

I discovered in System Settings → KeyboardShortcutsTyping that the Alternate Characters Key is set to Disabled.

I changed Disabled to Alt-Gr (right Alt key) and it works now. No need to change and reconfigure the keyboard type.

5

It's working now. Here's all I changed, maybe it helps somebody else:

  • Changed the keyboard type to Generic, 105 keys, intl., using the sudo dpkg-reconfigure keyboard-configuration command.
  • Removed all input sources to use from the list, except one.
  • Finally, in System Settings > Keyboard > Shortcuts > Typing, set Alternate Characters Key to Disabled.
0
2

Ubuntu 16.04 Dec 27, 2017

System Settings > Keyboard > Shortcuts > Typing changed the compose key to Right Alt

Now I can use the other keys Alt+o,o=° or Alt+',e=é and so on.

1
  • 2
    I think this path is no longer there on 18.04, at least on mine
    – matanster
    Jun 13 '20 at 15:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.