I tried to upgrade my system from Ubuntu 14.04. My laptop froze for a few hours. Not even the pointer did anything. So I switched off by pressing the power button for a few seconds. This uncompleted installation is the origin of my problem. When I reboot the system, grub appears and then, the following message:

[FAILED] Failed to start Load Kernel Modules
See 'systemctl status systemd-modules-load.service' for details

Plus some other lines that end with a final:

Failed to start Load Kernel Modules


When I open a command line by pressing CTRL+ALT+F1 I'm able to enter

sudo systemctl status systemd-modules-load.service

and I get the following output:

status systemd-modules-load.service


If I repeat the systemctl command, I get sometimes other process instead of 179, for example, 183.

Just in case it's needed,

sudo ls /lib/systemd/system/systemd-modules-load.service

gives me


(written in green)


outputs a lot of data. The red lines are the following ones:

First red line:


Second and third red line:


Fourth red line:


I really appreciate a little bit of help here. I don't know what to do next and I've searched the web finding nothing.

7 Answers 7


I found exactly what I needed in a discussion in ubuntuforums.org. Specifically, I was looking for the command:

dpkg --configure -a

The linked article above mentions four commands that may help resolve this problem and notes that they may need to be repeated "in no specific order":

apt-get update
dpkg --configure -a
apt-get dist-upgrade
apt-get -f install
  • 4
    The linked article threw me off a bit, because its first command (apt-get update) didn't help. But your pointer to the article's second command (dpkg --configure -a) did the job. Now that my machine is back in action (and I'm not stuck on my phone), I see that the article advises that the commands may need to be repeated "in no specific order". In case that article disappears, the other two commands are apt-get dist-upgrade and apt-get -f install.
    – Steve
    Oct 25, 2016 at 16:44
  • I'd just like to add that I'm working with Gem 5, and I'm trying to boot a disk image of Ubuntu 16.04.1/3 (server), and while it boots fine in QEMU, it gives me this error when running in full system mode in Gem 5. I'm sure that this solution has worked for others, but I wanted to add that it didn't fix it in my case.
    – user694859
    Dec 16, 2017 at 0:17
  • the apt-get update` only really needs to come before the apt-get dist-upgrade. You should avoid running a dist-upgrade if you don't know what you are doing, especially if dpkg --configure -a already works for you. Similarly, use apt-get -f install as a last resort as it can severely break your system.
    – virtualxtc
    Aug 28, 2018 at 21:32
  • I'm upgrade Ubuntu 18.04 to 20.04, also facing this issue, in the other hand also can't connect to the internet. Does this command need internet connection to run?
    – Tri
    Jul 23, 2022 at 9:47

I had the impression something went wrong on an update / kernel update:

Booted into recovery mode.

  • menu "root": manually revoked network

    ifconfig ethx <ip> netmask <mask> up
    echo "nameserver" > /etc/resolv.conf
    apt-get update
  • menu "dpkg": Repaired installation

  • back to menu "root": repair kernel initramfs

    update-initramfs -k all -u
  • +1 for the 'echo "nameserver" > /etc/resolv.conf' line :)
    – Tom
    Apr 11, 2018 at 17:27

Try this:

sudo apt-get remove nvidia-*
sudo apt-get autoremove
sudo nvidia-uninstall

and reboot.


I just had this problem with an ubuntu 16.04 installation. When I looked into journalctl | grep modules from the recovery root shell, I saw that it was trying to load modules from the 16.10 (newer) kernel. It was left over data on my USB stick because I did not format it in-between writing images to it (from a mac using unetbootin).

So a format of the USB stick, remake the bootable stick, and it was as good as gold.



In my case this might have happen when an update to the installation was going on and the system switched off without fully updated.

Press Ctrl+Alt+F1 (for command line interface)

After that,

sudo dpkg --configure -a
sudo apt-get dist-upgrade 
sudo apt-get -f install  (this command is optional, because the `dist-upgrade` command should have everything)

And lastly,

sudo init 6

(restart the system)

Now you will see Ubuntu 16.04 LTS without any error.

NOTE: It could take some time to update. In my case it took 45-60 min.

  • if your system is up to date, it won't take 45-60 min
    – virtualxtc
    Aug 28, 2018 at 21:33

For me it was a problem with my home partition, so running fsck /dev/sdb6 and answering all questions with yes solved it.

The affected partition might not be sdb6 on your system. In that case you will have to adjust the device name from /dev/sdb6 to the name used by your partition. If you don't know the correct pathname then you may be able to find it by running mount or by inspecting the contents of /etc/fstab (which you can do with cat /etc/fstab).


I also got

Failed to start Load Kernel Modules

every time at startup.

I did what Francisco suggested, but it didn't remove the error.

What did work though was to comment out the line nouveau in my /etc/modules file, the nvidia driver.

All my problems started when I switched driver so ofc it makes perfect sense. One thing that led me to it was the lines

... systemd-modules-load[279]: could not find module by name='off'
... Failed to insert 'off': No such file or directory

in my /var/log/syslog. Btw, I'm running Ubuntu 18.04.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .