15

My computer is set not to sleep or lock, but to blank the display after eg 10 mins. I have 2 monitors, which, prior to 16.04, worked as expected - the only noticeable thing was that, for whatever hardware reason, one took an extra moment or two to wake up after the screen blanked, but it worked fine.

After upgrading to 16.04, when waking from display blank, that monitor gets disabled - it wakes to only one monitor active. I have to go to Displays settings and re-enable (and re-position) it. I checked in XFCE Power Manager and this behaviour exists whether I have Handle display power management ticked or not - so far the only way I have found to stop it is to turn off display blanking altogether.

There are no power/sleep/etc settings on the monitor itself. Anything I can to do tell it not to lose/disable this display?

  • 1
    Obviously not how it should be. Probably the gr. driver and the screen do not communicate that well. The shortest way would be to press a shortcut which both enables and arranges bot screens after sleep. Alternatively, run a small background script, but I'd prefer the first option. Anyway, we'd need the output (from a terminal) of xrandr if the screen is correctly arranged . Could you post it somewhere? Please mention what you'd prefer. – Jacob Vlijm May 29 '16 at 21:18
  • 1
    Many thanks for the reply, and the very helpful offer to help resolve! I actually thought about an xrandr call to do it - it should be relatively straightforward and something I can handle. Ideally I was hoping for some lower level fix, but as you suggest, maybe it's the graphics driver itself - I'll experiment a bit more to see if I can reproduce in another 'buntu or with another screen. – Matthew May 30 '16 at 0:20
  • I have exactly the same issue. I set my displays.xml to read only so it doesn't overwrite my config of the layout, and I just have to log out and log back in and everything returns. I've used the intel driver and the generic and get the same result. – William Stearns May 30 '16 at 16:23
  • 2
    I followed Jacob's advice and added a keyboard shortcut for xrandr - yours will likely be different but mine should give you the gist: xrandr --output HDMI2 --left-of HDMI1 --auto Where HDMI2 is the misbehaving one. Allocated it to a keystroke in Keyboard settings so at least it's just a keypress to get it back - and surprisingly helpfully, xfwm4 puts the right windows back on each monitor. Still, a proper fix would be good... – Matthew Jun 1 '16 at 21:21
  • 1
    I have a similar setup, a similar problem, and a suboptimal solution which I note here as potential aid to others: get xrandr to turn the monitor off, then physically unplug and then plug the monitor back in. doing this without the xrandr step seems to cause the computer to crash. – Jeremy Jun 11 '16 at 22:05
1

Have you tried upgrade your Xubuntu 16.04 to 18.04? I remmember that in 16.XX version I had errors with monitors. In last version I don't have this problem... I hope it help you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.