1

I want to get Wifi N-only work with my Ubuntu 14.04 on Macbook Air 2013-mid which has BCM4360 802.11ac so it should work well with Wifi N-only also in Ubuntu 14.04. In Ubuntu

  • In Software and Updates > Additional Drivers, I see Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary).
  • MacbookAir6,2. I find the serial number by sudo dmidecode -s system-product-name but I get also a notice that something is broken MacbookAir6,2 Invalid entry length (0). DMI table is broken! Stop. Why getting such a notice about broken thing?
  • lspci -knn |grep Net -A2 gives the following so the answer here should apply but not; only difference is that I have ac wlan but they have newer with bgn.

Output of the lspci -knn |grep Net -A2

03:00.0 Network controller [0280]: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03) 
    Subsystem: Apple Inc. Device [106b:0117]
    Kernel driver in use: wl

Router

  • Router TP-link tl-wr1043nd v2 is in Wifi N-mode only.
  • Same hardware on OS X works with the Wifi N-mode only, so Ubuntu should also work with it.
  • You can set the band be Full HT40 (=20+20 MHz) or Dynamic 20/40kHz where your ultrabook will use 40MHz band because of Wifi N-only setting.

I do have b43 wifi card. I did the following based on the answer here, which enables slower wifi standards (B, G) but not N. The other thread has a case where the wireless device does not support Wifi N only, but my device supports it, so not relevant here.

sudo update-pciids
sudo apt-get install firmware-b43-installer
% reboot
sudo modprobe -r b43
sudo modprobe b43    
sudo rfkill unblock all  

Configurations that work but outside of the thread

  • AC-only (not tested)
  • NG-mixed with Dynamic 20/40 MHz or with Full HT40 (20+20 MHz), where Ubuntu uses only G band.
  • Slower bands

How can you Use Wifi N-only with Ubuntu 14.04 on Macbook Air 2013-Mid?

  • 3
    Possible duplicate of Installing Broadcom Wireless Drivers – Pilot6 May 30 '16 at 6:35
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. Did you read the answer? There is a list of adapters and drivers. – Pilot6 May 30 '16 at 6:58
  • @Pilot6 This is not duplicate! I found the core of the problem. My device supports Wifi ac and wifi N only too. OS X can use Wifi N mode directly. Ubuntu 14.04 cannot use it for some reason. The other thread has a case where the device does not support wifi N, which is not the case here. – Léo Léopold Hertz 준영 May 31 '16 at 9:10
2

For the wifi issue: MacBook Pros and MacBook Airs have very similar wireless cards (if not the same), so a simple sudo update && sudo apt-get install firmware-b43-installer should do the trick.

The reason for it not connecting to the router could be because it is a different type of connection, that the current driver does not support.

  • @Masi I did mention in my answer that the driver may not support that connection type. Linux is far less popular than the main stream operating systems (Mac & Windows), so it is common to see less time spent on Linux drivers and software. This can cause Linux drivers to be of lower quality and functionality, which is a potential reason why Wi-Fi N is not supported. – Flare Cat May 31 '16 at 10:18
  • @Masi It may be supported in Linux itself; that driver may not support it though. – Flare Cat May 31 '16 at 10:22
  • I was harvesting the farm and found the package broadcom-sta-dkms. It can solve the thing. A new thread about enabling its wl option here askubuntu.com/q/784487/25388 – Léo Léopold Hertz 준영 Jun 8 '16 at 15:45
  • Please, see the accepted answer. I find much more stability now after upgrading my router and phone. I have not experienced even a single failure with the new router. So I think the broadcom drivers work best if clients are updated too with the latest hardware. – Léo Léopold Hertz 준영 Aug 20 '16 at 6:53
1

You cannot but you can get more stability in the wifi connection in the hardware, which may lead to N support too sooner. Do

sudo apt-get install broadcom-sta-dkms
enable wl option 

Still much instabilities and interruptions in the network.

Sources

Router: many
Phone: Samsung Galaxy S4 gt-i9506
OS: Temasek's unofficial Cyanogenmod 13

Stability by Changes in Systems

I upgraded my wifi router and phone. I am experiencing much more stability in both networks with Wifi N. I have not experienced even a single network failure with my new router where I am using its two default bands (normal and its called 5G). The laptop has the details of wifi in the settings. It chooses smartly between the networks.

The laptop works also well with the hotspot network of Oneplus 2.

Router: TP-Link Archer MR200
Phone: Oneplus 2
OS: Cyanogenmod 13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.