4

The last version of COMODO AntiVirus for Linux, 64 bits version, cannot be installed on Ubuntu 16.04 LTS, 64 bits.

However, the 32 bits version of the program can be installed into a 64 bits OS, but... Is this a good idea?

Please, I need some help here, because it is intended to protect an "always connected" PC, with Ubuntu Studio 16.04 LTS (and the idea is to be "always" protected, a thing which we cannot get with CLAMAV).

  • Please provide us with more information such as what exactly you have tried and what has gone wrong as well as any error messages you were provided with. – user364819 May 29 '16 at 19:20
  • 3
    You certainly are entitled to install AV in linux, but it's not normally a required step like it is on a windows machine. I'm not recommending against it, however, I also don't want you to feel vulnerable without it. There is plenty of reading (google-fu) on the subject whether or not it's needed. In fact, Ubuntu takes a 'probably not needed' public stance. help.ubuntu.com/lts/ubuntu-help/net-antivirus.html – user508889 May 29 '16 at 19:27
  • If you use 64 bits Ubuntu, when you try to install COMODO 64 bits, you get the infamous error message: "not all dependences can be satisfied for this package". If you use 64 bits Ubuntu and you try to install COMODO 32 bits, then you can do it. But, my question is if to install a 32 bits antivirus into a 64 bits OS is a good idea. Linux isn't full free for hacker attacks (virus or any other trick). Linux needs antivirus and firewall software. Nobody is safe into the Internet jungle. So... – Juan May 29 '16 at 19:36
  • 2
    Why would it be bad? 64 bit can run 32 but with the right libraries. Obviously there are limitations to running 32 bit, but it isn't a bad thing. – user508889 May 29 '16 at 23:19
  • Thanks for your data. I'll install the 32 bits version. I'll trust in COMODO. – Juan May 30 '16 at 18:51
2

I found thisn helped install comodo x64 bit version, you have to manually install a dependency first then just download from commodo site the version x64.

libssl0.9.8 is no longer available in ubuntu 16.04 repositories. You can download and install manually the deb file from this link if you want libssl0.9.8 (clic on the link "security.ubuntu.com/ubuntu" when you reach that page).

the dependency: Dependency install

after install, you need this:

sudo /opt/COMODO/post_setup.sh

space bar throught the entire licence, then agree.

1
  1. sudo dpkg -i cav-linux_x64.deb
  2. sudo /opt/COMODO/post_setup.sh
  3. sudo /opt/COMODO/cav
  4. the comodo will run
  5. run diagnotics
  6. update Virus Database
  • The process you describe fails after the step 2. There is a lot of errors at that point. However, the main kernel of the software is running, but not with the real time routine. On old Ubuntu versions, it run (we had to do the same history you are telling). Maybe something is missing at 16.04 LTS version. – Juan Aug 5 '16 at 4:21
  • yes,i agree something is missing at the new version..i install it with this steps and it succeed..i don't know how it worked but i install it .. – ㅤㅤㅤ ㅤㅤㅤㅤ ㅤ Aug 5 '16 at 7:19

protected by Community Nov 5 '16 at 16:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.