1

First let me repeat the cliche that I'm pretty new in the field so please excuse me in any ingenuousness.

I've already setup a server with ubuntu 16.04 and done pretty much everything it takes to have maas provision nodes (of course I'll go on deploying other stuff for openstack if only I can pass this very stage) on it based on some straightforward guide (put there by a great guy code name "openstack in basement") I found on the internet. The bad luck is those comprehensive guides are revolving around ubuntu 14.04 and maas 1.7 (I'm not sure but definitely not maas 2.0) so as you know everything seems different from old version of maas from packages you need to install to maas gui and even commands. Ok let me cut it short here and get to my problem specifically.

In ubuntu server there's two network interfaces one connected to university network (since I'm going through all these as a uni project & I set it all up in uni lab) with static ip and access to internet, and the other one connected to a dedicated switch again static ip and both nics configured in /etc/network/interfaces :

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto enp3s0
iface enp3s0 inet static
address 172.16.63.100
netmask 255.255.192.0
gateway 172.16.40.12
dns-nameservers 10.1.1.100 4.2.2.4 172.16.0.159

auto enp5s0
iface enp5s0 inet static
address 10.1.1.100
netmask 255.255.255.0

# static route
up route add -net 172.16.0.0/18 default gw 172.16.40.12 dev enp3s0

In the maas gui under network tab there's two fabric-0 and fabric-1 with network information of public interface and private interface respectively. The gui for fabric-1:

enter image description here

Under DNS tab but unfortunately the public interface's ip is shown :

enter image description here

I couldn't figure it out how to change it to private interface's ip. By the way when I for the first time changed the setups in the BIOS of one of the nodes connected to switch to be pxe booted and restarted it, it presumably booted by network and received things from maas although through this process demonstrated some failing errors to connect to some addresses on the internet (I'm not sure why since it gets every thing from maas, doesn't it?) and finally the black page with:

Ubuntu 16.6 LTS ubuntu

ubuntu login:

appeared on the pxe booted node which I'm totally baffled what to do with that since I expect it to shutdown automatically. Well it did not and still no sign of enlisting that node on maas gui (still a 0 beside Machines under node tab)

Please guys help out of humanity, I'm somehow stuck on the verge of collapsing under burden of this dissertation which has barely started.

  • When you do sudo dpkg-reconfigure maas-region-controller does it show your 10.1.0.0 address? – user508889 May 29 '16 at 17:18
  • Also, I'm pretty sure you're missing packet forwarding and your iptables rules to push traffic from your lan out through your maas server for anything on the internet. – user508889 May 29 '16 at 17:21
  • Right now I don't have access to server (it's late at night here) but I'll do that as soon as next 10 hours. Yeah as you said I did not take care of package forwarding, please instruct me what exactly I need to do. Thank you so much for your assistance. – Ali May 29 '16 at 18:41
  • Wow, it seems the world begins to be a hospitable place for me. – Ali May 30 '16 at 7:25
  • hey @Ali , I also got a similar issue and kinda stuck with this. Neither i can login(same ubuntu login) or nor commission it from MaaS UI. Anything that would you like to suggest . I know i am asking you dis question more than an year later. I also did see your comment below and checked my Iptables, there are no rules set. Should I go ahead and set a rule from Mass Server to the Node(which i am trying to connect) .?? In the Node , getting error message saying ping time out 5 seconds(Looks like its not able to communicate to the maas server) – Mohan Sanagapalli Jun 20 '17 at 3:53
2

Well first I must say all the credits must go to our friend "bc2946088" who gave the vital clue, thank you again dude.

As he said I ran the sudo dpkg-reconfigure maas-region-controller command and changed the auto detected ip to 10.1.1.100. I also on the local PC from which I ssh to the maas, ran the route -p ADD 10.1.1.0 MASK 255.255.255.0 172.16.63.100 command and rebooted. After these when I hit the power of the node it exactly did what was expected, receiving stuff from maas and also getting thing from archive and finally shutdown. And best of all maas gui showed the node as New. Then I commissioned it (needed to hit the power button of that node) and it went on working seamlessly and status became Ready.

one more question, Now under DNS tab there are two entries

Should it look like that?

  • I deployed the mentioned node. When I run nslookup node01.maas , it doesn't seem to be able to resolve that, I get ** server can't find 101.1.1.10.in-addr.arpa: NXDOMAIN how can I fix this? – Ali May 30 '16 at 8:55
  • When I ssh to that deployed node and run nslookup node01.maas which is that node itself or nslookup 10.1.1.100 which is maas it says ;; connection timed out; no servers could be reached. Also it can't ping anything. Can anyone please explain what the problem is? – Ali May 30 '16 at 9:22
  • thanks for posting it mate ...!!!!! Saved a lot of time .up voted ..! – Mohan Sanagapalli Jun 21 '17 at 1:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.