Hi I have been searching on internet and tried to export the path of these libraries, but still I am getting an error.

Location of the libmwlaunchermain.so in my Ubuntu system is: "/usr/local/MATLAB/R2015a/bin/glnxa64".

What could be the possible solution? I need these files to run .exe file generated using deploytool.

  • /usr/local/MATLAB/R2015a/bin/glnxa64 not in your LD_LIBRARY_PATH ? .... ? Have you tried $ export LD_LIBRARY_PATH=/usr/local/MATLAB/R2015a/bin/glnxa64:$LD_LIBRARY_PATH && [name of executable] May 29, 2016 at 11:24

1 Answer 1


It was an error, while running executable file, I was passing the whole path for library "/usr/local/MATLAB/R2015a/bin/glnxa64" and LD_LIBRARY_PATH was then "/usr/local/MATLAB/R2015a/bin/glnxa64/bin/glnxa64".

I changed it to MATLAB location "/usr/local/MATLAB/R2015a".

Its working now.

  • 1
    What did you change to /usr/local/MATLAB/R2015a? LD_LIBRARY_PATH?
    – j08lue
    Jan 29, 2019 at 18:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .