I have a problem with my 530U4E/540U4E Samsung Ultrabook Backlight settings; the system doesn't seem detect the change in brightness settings. To fix it I tried the "Intel backlight Fix" because my hardware is mainly Intel based.

Heres a list of my ultrabook's hardware Specifications followed by how I tried to implement the following fix.

System Manufacturer SAMSUNG ELECTRONICS CO., LTD.  
System Model    530U4E/540U4E  
System Type x64-based PC  
System SKU  SAMSUNG SENS Series  
Processor   Intel(R) Core(TM) i5-3337U CPU @ 1.80GHz, 1801 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date   American Megatrends Inc. P08ACM.065.140226.dg, 2/26/2014
SMBIOS Version  2.7  
Embedded Controller Version 255.255  
BIOS Mode   UEFI  
BaseBoard Manufacturer  SAMSUNG ELECTRONICS CO., LTD.  
BaseBoard Model Not Available  
BaseBoard Name  Base Board  
Platform Role   Mobile  
Secure Boot State   On  
PCR7 Configuration  Binding Not Possible  
Windows Directory   C:\WINDOWS  
System Directory    C:\WINDOWS\system32  
Boot Device \Device\HarddiskVolume2  
Locale  United States  
Hardware Abstraction Layer  Version = "10.0.10240.16392"  
User Name   user-pc\user  
Time Zone   New Zealand Standard Time  
Installed Physical Memory (RAM) 4.00 GB  
Total Physical Memory   3.88 GB  
Available Physical Memory   2.04 GB  
Total Virtual Memory    4.57 GB  
Available Virtual Memory    2.71 GB  
Page File Space 704 MB  
Page File   C:\pagefile.sys  
Hyper-V - VM Monitor Mode Extensions    Yes  
Hyper-V - Second Level Address Translation Extensions   Yes  
Hyper-V - Virtualization Enabled in Firmware    Yes  
Hyper-V - Data Execution Protection Yes  

Name    Intel(R) HD Graphics 4000  
PNP Device ID   PCI\VEN_8086&DEV_0166&SUBSYS_C0E8144D&REV_09\3&11583659&0&10  
Adapter Type    Intel(R) HD Graphics Family, Intel Corporation compatible  
Adapter Description Intel(R) HD Graphics 4000  
Adapter RAM (2,142,291,968) bytes  
Installed Drivers     igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igdumdim32,igd10iumd32,igd10iumd32  
Driver Version (windows 10)  
INF File    oem159.inf (iIVBM_w10 section)  
Color Planes    Not Available  
Color Table Entries 4294967296  
Resolution  1366 x 768 x 60 hertz  
Bits/Pixel  32  
Memory Address  0xF7800000-0xF7BFFFFF  
Memory Address  0xE0000000-0xEFFFFFFF  

My first attempt I used the sudo command like in this article. I was told that using sudo could be bad so I tried what @zanna recommended to use sudo -i instead, but still doesn't work, maybe I did it wrong?

I tried it through nano and a No metadata error message came up but nothing changed. Is there anything else I can try?

If you know one id be happy to give it a shot, thank you in advance.

I Apologize in advance as I'm still learning to use the terminal, I'm a quick learner so no worries!

Edit: Just checked to see if I needed a specific from Intel if they had one and I found this https://01.org/ (for linux specific Drivers) though Ubuntu comes with this by default so it might not be the driver like some post suggest?

Update: Just tried another fix in this link This one doesn't work either, same metadata error appeared, like in the first one. I'll see if I can find more I can try and I'll post an update if I find something.

damien@damien-530U4E-540U4E:~$ sudo gedit /usr/share/X11/xorg.conf.d/80-backlight.conf
[sudo] password for damien:
(gedit:3942): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
** (gedit:3942): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-spell-enabled not supported
** (gedit:3942): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported
** (gedit:3942): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-position not supported
  • Thanks, I'll remember that one, just had another go at it using Gedit & nano under the sudo -icommand, still being stubborn though, no effect on the brightness setting. could it be the wrong backlight settings? – Damien Gorlick May 29 '16 at 8:21
  • Can anyone make sense of this? it might be the fix i have been looking for Thanks bugs.launchpad.net/ubuntu/+source/linux/+bug/1516320 – Damien Gorlick Jun 2 '16 at 3:43
  • its booting fine, ive just taken the splash screen out and the changed CMD lines i initially altered back to black as in the grub tutorial :) its just some things say fail though it still boots. i fixed a few issues in regards to PC name change to fix that local host one with success – Damien Gorlick Jun 2 '16 at 7:17


I just had a hunch after reading about fixing broken 1080p output and saw a slightly different configuration setting in this article Ubuntu 16.04 Skylake 6th Generation Screen Flickering

It turns out that the original configuration settings on this popular backlight fix were wrong http://itsfoss.com/fix-brightness-ubuntu-1310/ or at least for my setup.

To fix an intel backlight that does not work with the above fix we need to do the same thing again but "change" an option in its setting

First confirm its an intel backlight ls /sys/class/backlight/

if it is open sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf, And if it doesn't exist enter into the terminalsudo touch /usr/share/X11/xorg.conf.d/20-intel.conf, to create it

By default the file would be... Section "Device" Identifier "card0" Driver "intel" Option "Backlight" "intel_backlight" BusID "PCI:0:2:0" EndSection

if you had tried that this is what you need to change Option "Backlight" "intel_backlight", to... Option "AccelMethod" "sna"

Or just backspace everything in the file and copy below into it then click "save"

Section "Device" Identifier "card0" Driver "intel" Option "AccelMethod" "sna" BusID "PCI:0:2:0" EndSection

Once done just reboot and you can now enjoy adjusting the brightness settings! If you found this useful please like my answer and tell others about it who have that intel backlight issue, Thanks!


In my case working solution is Option "Backlight" "acpi_video1"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.