I am using both Windows 7 and Ubuntu 11.10 on a single system with the same hardware. While I'm making call through Gmail or Skype my voice is audible to others while I'm on Windows 7, but while I'm on Ubuntu 11.10 it's not audible to others, but I am able to hear their voice. But while I'm playing music on Ubuntu along with a call, the others are able to hear the music, but my voice is not audible for them.

Please give me a solution for this and tell me where I can change the microphone settings on Ubuntu 11.10.

  • I had the same issue, try: sound settings>input>connector and change it to "internal microphone". I'm not sure anyway. it worked on skype for me.
    – user32459
    Nov 10, 2011 at 13:45
  • I have the same problem, but on different hardware. Here is my bug report: bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/849967
    – rigved
    Nov 10, 2011 at 14:43

5 Answers 5


The settings for the microphone can be accessed by clicking on the sound icon at the top right bar, which looks like a speaker with the sound waves coming out of it.

If you click on that then you can see the option to open your sound settings. Do this and go to input, which is microphone. You might have a couple options like front mic or rear mic, and you might need to try out those options.

A lot of this has to do with your sound card which is usually on board your motherboard. Can you tell me what kind of motherboard you have?

Oh, and sometimes the problem lies within Skype, try to open the options in skype and see whether you have options for your mic.

  • My motherboard is MSI H55M-E21 with Intel chipset.
    – Teja
    Nov 11, 2011 at 13:28
  • my problem is clear now.thanx for ur help.
    – Teja
    Nov 11, 2011 at 14:15
  • @Teja, what did you do to fix the problem? Apr 5, 2015 at 13:51

In terminal write alsamixer and you will get a sound manager. Once in, press F4 to access capture settings. If any of the "Capture"-modules have a couple of lines underneath -------- , try marking the module with the arrow keys, and pressing Spacebar .

You will see some red text, which indicates, that the module is recording.

Maybe this will work.

  • yes, this works just fine. I was looking for a simple way of activating microphone without a recording application (just ear myself on the speakers) and ubuntu seems to have forgot this case. its a shame it requires a writen command because we cant reach the desktop with this kind of things
    – neu-rah
    Jan 13, 2013 at 14:37

Try reducing the Mic Boost on alsamixer to 0, doing so lowered the background noise so my voice was audible. It's not perfect but it seem usable on GoogleTalk/Skype, I tested it on the sound recorder.

Hope this helps.


The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:


tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).


Try changing the frequency of yourmic. This one worked for me. http://ubuntuforums.org/showpost.php?p=11385053&postcount=15

  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes.
    – Peachy
    Aug 25, 2012 at 15:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .