When booting or restarting a ThinkPad running 16.04 with 4.4.0-23-generic. I see a brief error or warning that states

TPM error (6)

Looking at the system, I see a bit of chatter in dmesg

$ dmesg | grep -i tpm
[    ] tpm_tis 00:05: 1.2 TPM (device-id 0x0, rev-id 78)
[    ] tpm_tis 00:05: TPM is disabled/deactivated (0x6)
[    ] tpm_tis 00:05: A TPM error (6) occurred attempting to read a pcr value
[    ] ima: No TPM chip found, activating TPM-bypass!

Should I change bios settings or deal with this in another way? It doesn't seem to hinder performance once a desktop manager is loaded.

2 Answers 2


On Thinkpad T540p, there is a field Security Chip in BIOS under the Security tab with options Active, Inactive and Disabled.

The error message you reported appears if this option is set to Inactive: "Security chip is visible, but is not functional."

In my case, any other option removes the error. Active means "Security chip is functional" and Disabled "Security chip is hidden and is not functional."

  • 2
    This solution worked for me on a Thinkpad T420s. Jun 20, 2016 at 20:44
  • activating the security chip in BIOS solved this for me Nov 13, 2016 at 20:15
  • Also worked for me on a W520.
    – revprez
    Mar 22, 2017 at 21:40

Well after find this bug report and comment...

Typically, just the existence of the word "error" in dmesg, especially without an accompanying end user impact, doesn't meet the standards of a bug. However, we can mark it Triaged for now, and see what develops.

It may just be a mild annoyance at this point. I'm going to ignore it for now until someone smarter than me can impart some wisdom.

Update: I saw the bios setting that listed the chip as:

  • off
  • on but inactive
  • on

I turned in on and the message no longer renders.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.