20

I have Dell XPS15, dual booting with Windows 10 and Ubuntu 16.04 LTS (novice to Linux), which came with a Type-C USB. I just bought a Dell DA200 adapter for the USB which works on Windows but doesn't on Ubuntu 16.04 LTS. I checked by running 'lsusb' with and without the adapter and confirmed the problem. Could someone please suggest a solution? Thank you.

13

contrary to what the other answers to this question suggest, the da200 adapter is not a displaylink device (unlike its predecessor, i believe). it's a "docking station" adapter that connects to the usb-c port, and provides hdmi, vga, ethernet, and usb ports.

currently there seems to be a problem with the graphics on this device. the laptop does see an external screen, but it will remain black. only when a low resolution is chosen (usually much lower than the preferred resolution of the monitor or tv that is attached) the display "works".

more information and details about this issue is available from these bug reports:

  • 3
    I also experience the graphics issue with a XPS 13 9360 and DA200. Lot's of research did not lead to a solution. Trying with a colleague's Apple "USB-C Digital AV Multiport Adapter" solves the issue for me. I will return the DA200 and buy one of these (and will find a different solution for the missing Ethernet). – justfortherec Nov 10 '16 at 12:45
  • detail.tmall.com/… This adapter was proved to work with XPS 13 and Ubuntu 16.04. – Yale Huang Jan 3 '17 at 5:21
  • Just a follow up. I tested the Dell DA200 on a XPS 13 9350 in yakkety with kernel 4.8.0-37-generic. There's still a black screen when you connect by HDMI port in any resolution besides the lowest. All the other ports work fine. – clvx 24 mins ago – clvx Feb 18 '17 at 13:20
  • You can patch the linux kernel to get higher framerates on the DA200, see the following patch: patchwork.freedesktop.org/patch/145853 – Octav O Apr 8 '17 at 16:54
1

This is apparently fixed in the 4.5 linux kernel https://bugs.freedesktop.org/show_bug.cgi?id=92932

http://ubuntuhandbook.org/index.php/2016/03/upgrade-linux-kernel-4-5-ubuntu/

  • 5
    Just tested on new Ubuntu 16.10 live USB (Yakkety Yak) with my Dell XPS 13 9350 laptop using the DA200 adapter, but unfortunately it still only displays HDMI at lowest resolution (800x600). Kernel version is 4.8.0.22-generic. – PKD Oct 15 '16 at 8:29
1

Try using the latest compatible kernel (i'm using 4.7.0-rc7 and it's working). You could also try to leave the plug inside the computer and reboot (still plugged). In my case, VGA is not working (Linux nor Windows) but the other plugs are working fine.

  • 1
    I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Sep 10 '16 at 15:04
  • Ok but there is the question "Could someone please suggest a solution?" and i suggest 2 solutions : try to update the kernel & try to reboot with the adapter plugged ... can you guide me updating the answer correctly ? – Max Sep 14 '16 at 9:16
1

As per the following bug it seeems to have been fixed.

If it still doesn't work for you check the kernel version uname -a.

In my case I was checking for any updates on the issue thinking it wasn't solved however when I tried it it simply worked.

According to this post on Dell commpunity someone got it to work with a patch for kernel 4.13 which I happen to have. I did not patch though.

If it's not urgent I suggest you wait for the next kernel image update.

protected by Community Jan 16 '17 at 23:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.