3

I have a working PXE boot, and can successfully install the 16.04 Desktop via PXE and NFS.

Now I'm trying to automate the PXE install, and I can't get past the installation's "Welcome" screen that asks for my language.

I've read through: https://wiki.ubuntu.com/UbiquityAutomation and https://help.ubuntu.com/16.04/installation-guide/amd64/apbs01.html

This is my pxe boot command:

LABEL Ubuntu 16.04 64-bit -- PRESEED
        KERNEL Ubuntu/16.04/amd64/vmlinuz.efi
        APPEND automatic-ubiquity file=/srv/install/ubuntu/16.04/amd64/preseed/custom.seed boot=boot=casper netboot=nfs nfsroot=myip:/srv/install/ubuntu/16.04/amd64 initrd=Ubuntu/16.04/am64/initrd.lz

And here is the top of custom.seed

ubiquity languagechooser/language-name select English
ubiquity localechooser/supported-locales multiselect en_US.UTF8
d-i debian-installer/locale string en_GB.utf8

But these does seem to be enough to get past the installer's first question.

How can I get past the first Welcome/language screen?

EDIT: I am using the CD Desktop Image that loads with a UI where you click the CD cion to install, not the netboot image.

2
  • I think most of these docs are for a server installation, not the desktop one with a GUI? May 28, 2016 at 19:31
  • I think one of your issues is the kernel parameter line: "boot=boot=casper" should be boot=casper.
    – MSumulong
    Aug 3, 2016 at 12:17

1 Answer 1

0

The trick ends up being to modify the kernel boot commandline in your PXE entry (or e.g. in a grub.cfg or txt.cfg file or similar), adding debian-installer/language=en.

For example, my netboot setup's grub.cfg has this entry:

menuentry "Desktop 20.04 Installer" {
   set gfxpayload=keep
   linux ubuntu2004/vmlinuz ip=dhcp nfsroot=192.168.0.1:/netboot/nfs/ubuntu2004 netboot=nfs ro file=/cdrom/preseed/ubuntu.seed boot=casper systemd.mask=tmp.mount automatic-ubiquity fsck.mode=skip noprompt keyboard-configuration/layoutcode=us debian-installer/language=en --
   initrd ubuntu2004/initrd
}

(This may work in combination with entries in the preseed file. I did not test removing those after adding the above...)


How I came upon this:

  • I've successfully preseeded everything else with my own installs, so had non-zero knowledge/experience here...
  • Like you, I had ubiquity languagechooser/language-name select English (US) in my preseed file. Not tested, but I suspect that changing this would change which language was initially selected in the GUI...
  • Referencing https://help.ubuntu.com/lts/installation-guide/s390x/apbs02.html#preseed-auto, which talks about kernel command parameters (though doesn't give any examples that aren't preseed snippets): I had previously been using a keyboard-configuration/layoutcode=us parameter, and that page suggests several parameters, including debian-installer/language=en.
  • From past installs, looking in /var/log/installer/syslog on an imaged system, I found that parameter mentioned:
Oct 16 00:37:33 ubuntu localechooser: info: debian-installer/language preseeded to 'en' (seen: false)
Oct 16 00:37:33 ubuntu localechooser: info: debian-installer/country preseeded to 'US' (seen: true)
Oct 16 00:37:33 ubuntu localechooser: info: debian-installer/locale preseeded to 'en_US.UTF-8' (seen: true)
  • Note how the other two parameters have seen: true... this gave me confidence to try the parameter out.
  • While the lines look like that still after adding the kernel commandline parameter, after adding debian-installer/language=en, things auto-ran and the parameter is now marked as "seen" earlier in this initial syslog.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.