1

In workbench the status of the server is STOPPED and the startup log message:

2016-05-28 11:14:37 - Checking server status...
2016-05-28 11:14:37 - Trying to connect to MySQL...
2016-05-28 11:14:37 - Can't connect to MySQL server on '127.0.0.1' (111) (2003)
2016-05-28 11:14:37 - Assuming server is not running

When I run:

sudo service mysql status

I get:

mysql start/post-start, process 3061
post-start process 3062

Could anybody help?

  • Checking the status after a few minutes it changed to: mysql stop/waiting – Dan More May 28 '16 at 15:31
0

Make sure that your /etc/mysql/my.cnf does not have bind-address set, then restart the server. This will allow connections from localhost.

  • I commented out the bind-address option and now I get this: – Dan More May 28 '16 at 18:53
  • well, the log is too long to post. there an error though: [ERROR] /usr/sbin/mysqld: unknown option '--explicit_defaults_for_timestamp' 2016-05-28 14:48:08 [ERROR] Aborting – Dan More May 28 '16 at 18:58
  • Can you upload your my.cnf to paste.ubuntu.com please? – Bob Carlson May 28 '16 at 19:01
  • OK, just did (I hope) – Dan More May 28 '16 at 19:06
  • What's the link? – Bob Carlson May 28 '16 at 19:08
0

There are many possible issues:

  • Make sure the service is really up and running: netstat -plnt | grep mysql
  • make sure it is on the address:port you expect it to see, for examlpe here you won't be able to connect from outside because the only IP with MySQL is localhost: tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 12460/mysqld. If you don't see it here but see in the processes (ps -eF | grep mysqld) then perhaps it is bound to socket only.
  • make sure the process is alive by logging in from console: mysql -u user -p
  • make sure the firewall(s) allow(s) your remote host to connect to the server to that port (e.g. nmap, windows version available too)
  • make sure there's no typo in workbench connection settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.