9

After upgrading to Ubuntu GNOME 16.04 with GNOME 3.20 I have found that if I tap my touchpad it clicks which is something I do not want due to a faulty touchpad, previously I was able to disable this through the gnome-control-center, but seemingly there is no way to do this any more through there, so how do I do it? Also, even though it is set to false in gsettings and the dconf-editor seemingly for some reason somewhere in the system it is also set to true as it is behaving as such. I am also unable to set natural scrolling or any of the other touchpad settings seemingly, why not?

  • Please edit your question and add output of xinput terminal command. – Pilot6 May 28 '16 at 17:24
  • @Pilot6: No need, I solved it! – user364819 May 28 '16 at 17:34
  • 1
    This is not universal. With libinput tapping is disabled by default. But it is possible to do it with xorg-synaptics as well. But libinput is good either way. But unity-control-center does not have settings for it yet. – Pilot6 May 28 '16 at 17:43
  • @Pilot6 I don't see any package xorg-synaptics. My apt-cache search xorg-synaptics returns nothing. I have all repositories enabled and sources list updated – Severus Tux May 28 '16 at 18:17
  • 1
    There is no such package. In Ubuntu it is xserver-xorg-input-synaptics. It is installed by default. But libinput overrides it if installed. – Pilot6 May 28 '16 at 18:18
8

To be able to set these settings through Terminal or through the gnome-control-center you need to make sure that you have xserver-xorg-input-libinput installed. It appears to be a bug that it is not already installed by default, in order to install simply run:

sudo apt-get install xserver-xorg-input-libinput

After doing so and then logging out and in again you will find new settings in the gnome-control-center's Mouse & Touchpad settings:

New Mouse & Touchpad settings

You should now also be able to set the touchpad settings through the dconf-editor and gsettings in Terminal.


Related: LP Bug #1586657

  • Works perfectly – Severus Tux May 28 '16 at 17:26
  • You probably do not need to, you should be able to set gsettings set org.gnome.desktop.peripherals.touchpad click-method none anyway. In the same key, other settings are stored. – Jacob Vlijm May 29 '16 at 6:45
  • @JacobVlijm: I tested that already, if you set any of the settings through gsettings or dconf-editor it has no effect whatsoever unless you install that package. It's a bug, I've even linked the relevant bug report. It should work as you said, but it doesn't without that package. – user364819 May 29 '16 at 11:15
  • I see you've posted duplicate answers. One of these is a dupe, therefore. Care to flag :)? – RolandiXor Jun 8 '16 at 23:13
  • @RolandiXor: I voted to close the other one as a duplicate of this one because if you look at the question this one is more broad and the other one fits into it. – user364819 Jun 9 '16 at 9:55
-3

I just installed gnome-control-center in Unity, and the tap-to-click check box is there, just to the left of two finger scroll and natural scrolling.

Screenshot

  • What version of the gnome-control-center did you install? There is no such option in the GNOME 3.20 one that I am running. – user364819 May 28 '16 at 15:58
  • Hmm... I guess I just installed the "default" one. sudo apt install gnome-control-center – Nick Chackowsky May 28 '16 at 16:13
  • Yes, I know, it's the one the standard repos, but they do not have the latest one, if you want the latest you have to add the Ubuntu GNOME (semi-unofficial, but maintained by those who maintain all of Ubuntu GNOME) ppa:gnome3-team/gnome3-staging and ppa:gnome3-team/gnome3 PPAs. – user364819 May 28 '16 at 16:29
  • I understand that this should work on Unity too, so if you really want to help you can install it, but I think that this has to do not with the gnome-control-center, but rather some gsettings bug because it's set manually to the correct thing, but something seems to be ignore that. – user364819 May 28 '16 at 16:30
  • The problem has now been solved (as you can see by my answer) so please delete your answer. – user364819 May 28 '16 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy