1

I have wifi and Bluetooth modules RT3290. Wifi is working fine but Bluetooth is shown as disabled under Bluetooth settings. Can anyone help me fix this?

Screenshot

  • There is a longstanding, ongoing bug about this card, affecting a lot of users, in different ways. Here is the bug. We might need to wait until a complete fix is released. – user308164 Aug 3 '16 at 5:40
3

I use Ubuntu 16.04 (Kernel 4.8)

  1. Run

    sudo apt-get update
    sudo apt-get install build-essential linux-headers-generic
    
  2. Download zip from here on GitHub and unzip it to Desktop.

  3. Change your directory to new unzipped directory (i.e. ~/Desktop/rtbth-dkms-master).

  4. Run the following commands one by one

    make
    sudo make install
    sudo cp -r ~/Desktop/rtbth-dkms-master /usr/src/rtbth-3.9.3
    sudo dkms install rtbth/3.9.3
    sudo nano /etc/modules
    
  5. Add rtbth at the end, then Ctrl+O and ENTER (to save the file) and Ctrl+x to close the editor

  6. Reboot

Ref : https://askubuntu.com/a/828925/703994 ; https://askubuntu.com/a/904222/703994

| improve this answer | |
  • Actually it should be "sudo chmod +x *", means all files. – N.Sinha Jun 26 '17 at 8:28
  • Most of the files were C files so I was kind of skeptical about it. Agree with you and I would appreciate if you could advise on the same. – N.Sinha Jun 26 '17 at 8:37
  • I tried this way but didn't work for me. Using above approach although I am not able to pair my devices but at least I can see a bluetooth icon on my staus bar. – N.Sinha Jun 26 '17 at 11:44
  • Worked for ubuntu 19.04 too. – Shubham pokhriyal May 17 '19 at 15:45
0

It is a supported card for bluetooth http://www.ubuntu.com/certification/catalog/component/pci/1814%3A3298/

There is a to getting it working with bluetooth here Ralink Bluetooth not working in Ubuntu 13.04

The second answer shows how to compile it yourself which you will need to do if the modules in the archive don't load because the kernel has changed since they where built

| improve this answer | |
0

A fix that was reported to work is from a github site, to install

sudo apt-get install git dkms build-essential linux-headers-generic
git clone https://github.com/f1u77y/rtbth.git
cd rtbth
make 
sudo make install

Reboot

| improve this answer | |
  • Thank you for the suggestion, but it didn't work – Mina Aboud May 28 '16 at 15:08
  • I would uninstall it then with cd rtbth && sudo make uninstall – Jeremy31 May 28 '16 at 15:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.