0

This question already has an answer here:

I have HP i3 laptop and I recently install Ubuntu 16.04 LTS and I could not detect my home wifi. Later I found out that the wifi gets connected only if Im like a feet near the router. It does not work even 5 feet away, where in windows 7 (dual boot) it works even 12-15 feet away. Please help me fix this. I tried every solution given in similar posts. But nothing worked.

marked as duplicate by Pilot6, muru, Videonauth, Eric Carvalho, Jeremy31 May 30 '16 at 19:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • If you have Secure Boot enabled, the driver may not install. – Pilot6 May 28 '16 at 11:11
0

I found the solution for this

open terminal and run

iwconfig

Note down the wlp number, in my case it was wlp13s0

Now download the driver from this link

And unzip and copy it to the Desktop. The final result should be like you should have a folder named rtlwifi_new-rock.new_btcoex in Desktop.

Now go back to terminal and cd to that folder. that is

cd Desktop
cd rtlwifi_new-rock.new_btcoex

Now run these commands 1 by 1

make
sudo make install
sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=2

By now your wifi should be strong and start working, but follow below commands to make the settings permanent

sudo ip link set wlp13s0 up
sudo iw dev wlp13s0 scan
echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf

This should fix the wifi and no reboot required.

  • 1
    This way you will have to re-install the driver after each kernel upgrade. I packed this driver as a DKMS PPA. – Pilot6 May 30 '16 at 18:26
  • You don't need the rock.new_btcoex branch either, it was merged with the master branch months ago. I think Pilot6's dkms.conf file is in there now also – Jeremy31 May 30 '16 at 19:19
  • When I run sudo ip link set wlp13s0 up i get "Cannot find device 'wlp13s0' " – Nick Pineda Nov 30 '16 at 13:50
  • Not all devices are named wlp13s0. So check the name of your device using the command iwconfig – mac Dec 5 '16 at 12:24
  • in my iwconfig. I can only see lo and eno1. How can I install wlp13s0 ?? – Jishad Dec 4 '17 at 4:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.