1

I have an HP Envy 15 with the RT3290 from ralink. It had Win8 on it which I have completely removed and installed ubuntu 16.04 on it.

I have been trying to get the wireless to work and haven't been able to.

I have followed these two guides here:

How do I get a Ralink RT3290 wireless card working?

How do I get an RT3290 wireless card to work?

and have compiled the source, generated the module and it is installed. I also added the module in /etc/module file so it will launch at boot. lsmod shows it there:

:/usr/src$ lsmod | grep rt
rt3290sta            1155072  0

:/usr/src$ lspci
08:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe
08:00.1 Bluetooth: Ralink corp. RT3290 Bluetooth
..with -n 
08:00.0 0280: 1814:3290
08:00.1 0d11: 1814:3298

but ifconfig still shows this:

rename6   Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:17 

:/usr/src$ ifup rename6
Unknown interface rename6

:~/Downloads/RT3290_Linux_v2600$ iwpriv 
virbr0-nic  no private ioctls.

rename6   Available private ioctls :
          set              (8BE2) : set 1024 char  & get   0      
          connStatus       (0004) : set 1024 char  & get 2047 char 
          driverVer        (0005) : set 1024 char  & get 2047 char 
          bainfo           (0006) : set 1024 char  & get 2047 char 
          descinfo         (0007) : set 1024 char  & get 2047 char 
          radio_off        (000A) : set 1024 char  & get 2047 char 
          radio_on         (000B) : set 1024 char  & get 2047 char 
          show             (0015) : set 1024 char  & get 2047 char 
          adhocEntry       (0016) : set 1024 char  & get 2047 char 
          bbp              (8BE3) : set 2047 char  & get 2047 char 
          mac              (8BE5) : set 1024 char  & get 1024 char 
          rf               (8BF3) : set 2047 char  & get 2047 char 
          e2p              (8BE7) : set 1024 char  & get 1024 char 
          stat             (8BE9) : set   0       & get 2047 char 
          get_site_survey  (8BED) : set   0       & get 1024 char 

virbr0    no private ioctls.

eno1      no private ioctls.

lo        no private ioctls.

lspci -v output:

08:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe
    DeviceName: Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Ada
    Subsystem: Hewlett-Packard Company Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at 61510000 (32-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: rt2860
    Kernel modules: rt2800pci, rt3290sta

The above lspci -v would seem to show that I have two kernel modules for this device, so I ran modprobe to remove rt2800pci and did lsmod to confirm it is gone. but when I ran lspci -v again it still shows.

I also searched for the kernel and rt3290sta.ko is present:

:/lib/modules/4.4.0-22-generic/kernel/drivers/net/wireless$ ls
adm8211.ko       ath           b43        hostap    libertas           mwifiex   ray_cs.ko      rt2x00        zd1201.ko
airo_cs.ko       atmel_cs.ko   b43legacy  ipw2x00   libertas_tf        mwl8k.ko  realtek        rt3290sta.ko

davy@davy-envy:/lib/modules/4.4.0-22-generic/kernel/drivers/net/wireless/rt2x00$ cat /etc/modprobe.d/blacklist-ralink.conf 

#Wireless drivers conflicting with rt3290sta
blacklist rt2800pci
blacklist rt2x00pci  
blacklist rt2860

I tried rebooting, and to search in /var/log/messages and dmesg, both files are empty, not messages. So I greped the whole /var/log folder for anything rt3290 but I got nothing.

So now I am out of ideas.

0

After a lot of tests under Ubuntu 16.04 on an HP ProBook 4540s with ralink3290 wireless card, the package that works correctly is the RT3290_u16, is the only one.

The others packages found on internet will install correctly the driver but fails on start-up, you will see errors by typing dmesg after the networking restart command.

Follow the link posted by D.Zou user and download the RT3290_u16.

  • that's odd, my dmsg file was empty, lots of stuff in syslog file but there was no error messages related to this rt3290. Do you have an example of the error message that you got? – D.Zou May 30 '16 at 15:47
  • 1
    @D.Zou no, i have not, because now the driver is working and i haven't saved the previously dmesg logs. I remember that the last dmesg message was "RTMPrt3xSetPCIePowerLinkCtrl.===> 1e" and nothing more. The "eno1" (interface name offered by ralink) from "iwconfig" command was not found. Now, instead, i see more stuff after the message above like "rt_ioctl_giwscan / rt_ioctl_siwfreq::SIOCSIWFREQ(Channel=6) / SSDA:(Two) Antenna Configuration" and so on. The opened point is that the wireless interface is not mounted automatically at startup, every time i need to launch the script "load.sh". – CptUnlucky Jun 1 '16 at 9:44
  • sorry for the delay, you are right, wifi interface is not loaded at startup for some reason – D.Zou Jun 19 '16 at 1:18
0

just found this post, http://onthim.blogspot.ca/2015/06/install-ralink-rt3290-wi-fi-driver-on.html the driver file has u16 version for U16. install that and it works.

Edit: You can also reinstall Ubuntu 16 under the OEM mode, that seems to have mysteriously fixed the wifi module. --July 4th

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.