1

On typing echo 1 > /sys/bus/pci/slots/$4/power, I get this error:

bash: /sys/bus/pci/slots//power: Permission denied

Here is the output of lscpi -vvon my system:

02:00.0 Multimedia controller: Digital Devices GmbH Octopus DVB Adapter
        Subsystem: Digital Devices GmbH Cine S2 V6.5 DVB adapter
        Physical Slot: 4
        Flags: fast devsel, IRQ 46
        Memory at c7400000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [50] Power Management version 3
        Capabilities: [70] MSI: Enable+ Count=2/2 Maskable- 64bit+
        Capabilities: [90] Express Endpoint, MSI 00
        Capabilities: [100] Vendor Specific Information: ID=0000 Rev=0 Len=00c <?>
        Kernel driver in use: ddbridge

06:00.0 Multimedia controller: Digital Devices GmbH Max
        Subsystem: Digital Devices GmbH Max S8 4/8
        Physical Slot: 3
        Flags: fast devsel, IRQ 49
        Memory at c7300000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [50] Power Management version 3
        Capabilities: [70] MSI: Enable+ Count=2/2 Maskable- 64bit+
        Capabilities: [90] Express Endpoint, MSI 00
        Capabilities: [100] Vendor Specific Information: ID=0000 Rev=0 Len=00c <?>
        Kernel driver in use: ddbridge
1
  • 2
    What is $4 supposed to be? Bash is seeing it as empty, hence the // in the path. Once you figure out what should be in place of $4 (which I believe means the fourth argument of a script), you should have it. May 27, 2016 at 23:53

1 Answer 1

3

echo won't work like that.

You would need use sudo tee instead like so to allow permission:

echo 1 | sudo tee /sys/bus/pci/slots/4/power

Also, I think you probably meant to specify slot 4 which would be 4 instead of $4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.