How would I go about fixing this error? I have pycharm installed through a ppa that I have been using for years in various computers.

W: GPG error: http://ppa.launchpad.net/mystic-mirage/pycharm/ubuntu xenial InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY DD969F10A7E2BCD2
W: The repository 'http://ppa.launchpad.net/mystic-mirage/pycharm/ubuntu xenial InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: There is no public key available for the following key IDs:

1 Answer 1


EDIT: You need to add it to apt:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys DD969F10A7E2BCD2

First and incorrect answer:

They changed the GPG key they use to sign packages. Try running this in a terminal:

gpg --recv-keys DD969F10A7E2BCD2

  • gpg: no keyserver known (use option --keyserver) gpg: keyserver receive failed: bad URI May 28, 2016 at 1:15
  • Try: gpg --recv-keys --keyserver pgp.mit.edu DD969F10A7E2BCD2
    – Josh M.
    May 28, 2016 at 1:17
  • worked but still same error on apt-get update May 28, 2016 at 1:18
  • It needs to be added to apt, try running sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys DD969F10A7E2BCD2
    – Josh M.
    May 28, 2016 at 1:50
  • keyserver.ubuntu.com --recv-keys DD969F10A7E2BCD2 gpg: requesting key A7E2BCD2 from hkp server keyserver.ubuntu.com gpg: key A7E2BCD2: public key "Launchpad PPA for Mystic-Mirage" imported gpg: Total number processed: 1 gpg: imported: 1 (RSA: 1) May 28, 2016 at 1:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.