2

I just installed the new ubuntu 16.04 from 15.10, where I had set up a printer LBP6020. I'm following this guide

I found same steps across the net, so I guess it is quite common. Anyway, when I upgraded to 16.04 tried to install it again using same steps, no success or whatsoever. When I issue a command /etc/init.d/ccpd status I get not two not one but like 5 rows of numbers, maybe about 50-70.

Otherwise, accessing the printer from the cups web based interface, I can see it and I can assign it a task to print a test page, although it shows job completed I don't see anything.

CUPS_ConfigPath = /etc/cups/
LOG Path        = None
UI Port         = 59787

Entry Num  : Spooler    : Backend   : FIFO path     : Device Path   :   Status 
----------------------------------------------------------------------------
 [0]    : LBP6020   : ccp       : //localhost:59687     : /dev/usb/lp0  : New! !

Don't know what the issue is, maybe have to wait for new drivers?

  • When you look at the queue, are there still print jobs pending? Does the printer show as paused? When you open the Printer window GUI, is there a pause icon overlaid on it? – Dorian May 27 '16 at 18:35
  • The printer shows as idle and no jobs are pending, it all shows under complete jobs. I can now access the 16.04 only over ssh so I use only cups web interface. – Nick May 27 '16 at 18:40
  • Something to try that fixed my Brother printer. CUPS Web Interface : Printers menu, select your printer, under Administration dropdown, select "Modify Printer". See if it shows up as an option under local or network depending on your setup if it's already connected. Select it and press continue. Leave all other settings the same, at the last window, press the button "Modify Printer". This worked for me. – Dorian May 27 '16 at 19:08
  • @XToro , tried that the printer status changed from Idle to Idle - "Sending data to printer", still jobs go to completed without print out. – Nick May 28 '16 at 12:43
  • Sorry, It says I don't have enough experience to comment above. Did you manage to fix this problem? I'm having the same issue too. Thanks – ryanfitton Jun 29 '16 at 21:24
4

I've done some digging on this issue. I have found a way on how to get the Canon LBP6020 printer working.

My Ubuntu version is 16.04 64-Bit with the Canon CAPT Printer Driver Version 2.70.

Firstly I had to setup Ubuntu so it could install 32-bit packages. Even though we're installing 64 Bit Canon drivers, some parts of the installation will need 32-bit packages installing. To get this setup I followed the instructions here: Installing 32-bit libraries on Ubuntu 14.04 LTS 64-bit, running the code:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386 libpopt0:i386

Then for installing the Canon packages, I followed these instructions from the French Ubuntu docs: https://doc.ubuntu-fr.org/imprimante_canon_capt2, please take note of the parts where the instructions mention installing the libglade2-0 package and these 32-bit packages: libatk1.0-0:i386,libcairo2:i386,libgtk2.0-0:i386,libpango1.0-0:i386,libstdc++6:i386,libxml2:i386,libpopt0:i386. You will also have to update the /etc/init.d/ccpd file with what is mentioned in the instructions.

I won't re-post the instructions here as the page linked above includes all of the instructions I used for my setup to work properly, hopefully this will work for you too.

Another issue I ran into, was when running Google translate on the French instructions, Google translate changed some of the text within the commands. It's best if you can install any commands from the original non-translated version (I kept the translated and non-translated pages side-by-side).

Cheers, hope this helps.

  • Thanks, @ryanfitton! Finally managed to do it! For now its on a brand new virtual server running 16.04 but I think I have to delete first all files and everything connected to previous installations! – Nick Jul 9 '16 at 14:43
  • @Nick fantastic. Glad you've got it working. I had to uninstall all of my previous settings too. I think I will be buying a different brand printer next time, Canon drivers seem to be a pain. – ryanfitton Jul 9 '16 at 16:53
  • thought about the same. This time won't go for the best deal. Will go through most supported devices first and then will select the next one.. – Nick Jul 9 '16 at 17:02
  • Also, You might need to check all dependencies are installed using: ldd /usr/bin/captfilter – GuySoft May 14 '17 at 8:11
  • I am intrigued at all the talk of installing 32bit components; I recently have installed the 2.7 64bit CAPT driver; on a 64bit 16.04 system; and it works fine; 1)install drivers; 2)register ppd 3) register printer with ccpd daemon; I would suggest the french translation is NOT now needed – pdc May 14 '17 at 9:07
3

I tried all the other answers but none worked for me. This was the only way it worked in my case (Xubuntu 17.04):

Download a script canon_lbp_setup.sh from russian community;

cd ~/Downloads
chmod +x canon_lbp_setup.sh
sudo dpkg --add-architecture i386
sudo apt-get update
./canon_lbp_setup.sh

There could be errors about dependencies; if so, run

sudo apt-get install -f

The only dependency that was not found in our repos was libpng12-0, I found it here, downloaded the .deb package and installed it using:

sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_amd64.deb

Every time you execute sudo apt-get install -f to install some dependency you have to run the script ./canon_lbp_setup.sh again.

  • Good for me I know Russian (so are installation messages' language). But the script worked for me flawlessly even without those dependency errors. Thank you! The only solution that worked. – Orif Khodjaev Aug 24 '17 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.