3

Oh boy... I have been a Linux user for three weeks now, and I really don't know what to do anymore :-( I tried to install Telegram on my Linux Ubuntu 16.04 LTS through various ways but with no success. Now I have a defunct "Telegram Desktop" icon in Dash, but I am not able to remove it. This is what I did:

  1. I tried to install "telegram-sergiusens" through Ubuntu Software. This didn't work though, actually I couldn't even find the whole Telegram on my system. Result: I removed the application through Ubuntu Software.

Next, I tried to install Telegram via terminal. I followed the instructions at Pupuweb. This is what I did:

sudo add-apt-repository ppa:noobslab/apps
sudo apt-get update
sudo apt-get install telegram-desktop

This didn't go without complications either. I received the following error message:

E: Unable to locate package telegram-desktop

Well, I suppose that only the personal package archive (PPA) got installed, not the application. Therefore, I followed another set of instructions to remove the installation (I ran the commands to purge the application though, just to make sure):

sudo apt-get purge telegram-desktop
sudo add-apt-repository --remove ppa:noobslab/apps

Now, I tried to follow YET ANOTHER set of instructions. This time I downloaded I file called "tsetup.0.6.15.tar.xz" from https://desktop.telegram.org. The instructions went as follows:

  1. Extract the file (right-click the icon and choose "extract here"; you will now have a folder called "Telegram"
  2. Move the file to /opt. In order to do this, you have to open the file manager with root privileges. To do that:
  3. sudo nautilus

After executing command number 9 in the terminal, however, I receive the following error message:

(nautilus:1061): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (nautilus:1061): CRITICAL **: Another desktop manager in use; desktop window won't be created Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory Please ask your system administrator to enable user sharing.

Weird enough, some sort of file manager window did pop up, but I am not sure if this happened with the root privileges mentioned above. Well, I tried to move the "Telegram" folder to /opt, but nothing happened. Out of curiosity, I opened the folder that was extracted to the "Downloads" folder, and I was able to open to application. However, the icon on the launcher was a gray question mark, so I wasn't yet quite satisfied. I deleted both the "Telegram" folder and "tsetup.0.6.15.tar.xz". They can be found from my trash bin at the moment.

Last but not least, I gave a try for the final set of instructions (I cannot post the link as a new user, but it's a thread called "How to install Telegram Desktop in Ubuntu 14.04 LTS [duplicate]" on the very forum). This is what I did:

sudo add-apt-repository ppa:atareao/telegram
sudo apt-get update
sudo apt-get install telegram

After this, I still wasn't able to find Telegram through Dash. Therefore, I tried to remove the installation I made by:

sudo apt-get purge telegram sudo add-apt-repository --remove ppa:atareao/telegram

Now I am baffled. I've been a Linux user for three weeks now, and I really would appreciate your help! :-) I'd like try again from the scratch, but I am not able to remove the ghost icon from the Dash.

  • 3
    Just an FYI... sudo nautilus is not a good idea. It can wreck your system. Always use terminal programs to perform the task if sudo is required. – Android Dev May 27 '16 at 16:12
  • 1
    I went to check out Noobslab's PPA and saw that telegram-desktop is not packaged for Ubuntu 16.04, so that's why apt couldn't find it. – edwinksl May 27 '16 at 16:43
  • 1
    FYI, I have just managed to install Telegram using the atareao PPA. – edwinksl May 27 '16 at 16:51
  • Try moving through the Terminal sudo mv /PATH/TO/TELEGRAM /opt – UniversallyUniqueID May 27 '16 at 17:38
3

It looks like you have basically undone all the steps, so you should be back to a clean slate. Perhaps even restart your computer before proceeding just to make sure.

The following steps worked for me on Ubuntu 16.04. To install Telegram, try:

sudo add-apt-repository ppa:atareao/telegram
sudo apt update
sudo apt install telegram

You should be able to find Telegram in your dash. If you can't, press Alt+F2 and enter unity to reload Unity. Try finding Telegram in your dash again.

  • 1
    Thanks for your replies! First, with respect to the defunct Telegram icon in Dash, it disappeared after rebooting just like you told me. Sometimes we can forget all the magic that one simple reboot can make, can't we? ;-D Second, concerning the installation, those three commands succesfully installed Telegram on my system. However, SYSTEM REBOOT REQUIRED AGAIN! Thanks for that as well :-) – Jayaguru-Shishya May 31 '16 at 19:25
  • @Jayaguru-Shishya Awesome! Please mark the answer as accepted so that people in the future know it works. – edwinksl Jun 1 '16 at 5:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.