1

I downloaded the docker toolkit from docker. I tried to change the .basrc, .profile, .bash_profile, /etc/environment file by adding /usr/local/bin/ or /usr/local/bin/docker-machine but I am still not able to run docker-machine in the command line. I get a command not found error.

I have docker-machine-Linux-x86_64 file in my /usr/local/bin/docker-machine folder. I am only able to run ./docker-machine-Linux-x86_64 when I'm in that folder.

Please help, thank you.

  • What does echo $PATH show? Can you run with the full path : /usr/local/bin/docker-machine/docker-machine-Linux-x86_64 ? – belacqua May 27 '16 at 20:19
  • The full path works too. But trying your solution made docker-machine command work. Thanks a lot. – user2014905 May 28 '16 at 1:38
  • Great -- that's good to hear. – belacqua May 28 '16 at 23:41
3

I would move your existing directory out of the way and re-install per the instructions. The instructions on the docker page will create the executable in /usr/local/bin/docker-machine, so this conflicts with the structure you have now.

sudo mv /usr/local/bin/docker-machine{,.old} # move dir to docker-machine.old

change to root, and install via curl (the command here is copied verbatim from https://github.com/docker/machine/releases):

sudo -s
curl -L https://github.com/docker/machine/releases/download/v0.7.0/docker-machine-`uname -s`-`uname -m` >/usr/local/bin/docker-machine && \
  chmod +x /usr/local/bin/docker-machine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.