2

I am using Ubntu-GNOME 16.04 with GNOME 3.20

When I install Nvidia graphic drivers by sudo apt-get install nvidia-361 , I am facing the following problems.

During the installation of Nvidia-361, it asks me to select Default Display Manager with the following options

  • lightdm
  • gdm3

Consequences of selecting lightdm :

The login screen becomes like this :

enter image description here

I don't want this screen. I want the Default (nice) GNOME login screen.

Furthermore....

When I enter my password and press enter, I get this screen for about 5 seconds :

enter image description here

Consequences of selecting gdm3 :

Well I get nothing!

After rebooting, Ubuntu loads ... then all of a sudden my display turns of. No Light. I have waited enough but alas :( no change.

NOTE:

I have tried both nvidia-361 in default repositories and nvidia-361 from ppa:graphics-drivers/ppa. No difference.

I also tried installing nvidia-364 and nvidia-367 from graphics-drivers:ppa , alas :( no much difference.

Using nvidia-364 or nvidia-367 :

When I tried these drivers, I could get GUI back. But I got stuck on the login page : login loop

  • What about nvidia-364 from the graphics drivers PPA, or even 367? – TheWanderer May 27 '16 at 15:27
  • @Zacharee1 I have not tried them. thought they were beta – Severus Tux May 27 '16 at 15:28
  • They might be, but if they work then what's the issue? :p – TheWanderer May 27 '16 at 15:29
  • I have a maxwell nvidia card, and my display wouldn't work on 16.04 with anything older than 364 from the ppa (or nouveau, but the performance was awful). – Andrew Keech May 27 '16 at 15:31
  • What Nvidia graphics card is it? Does your Nvidia card have prime support? – octoquad Jun 2 '16 at 15:44
6

You most likely have hit this bug: https://bugs.launchpad.net/ubuntu-gnome/+bug/1559576 which renders Nvidia prime cards currently unusable. You can maybe try some workarounds provided in the comments, but these might not work. However please do share your findings!

  • Yes. This is very much related. Thanks for the link :-) – Severus Tux Jun 2 '16 at 15:53
  • 1
    This bug was updated with a work-around: sudo apt install --reinstall xserver-xorg-legacy. This seems to work for me; I am using 17.04 with nvidia-375, but the suggestion in the bug report is for 16.04. – PJ Singh May 4 '17 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.