2

I have a brand new Dell Inspiron 5000 with Windows 10. I've shrunk the windows partition and tried to install an Ubuntu 16.04 LTS to have a dual boot. The installation (sda8 for / and sda9 for /home) runs well until it tries to install grub. At this point it fails with a "critical error" and I'm not able to boot Ubuntu.

Trying to repair grub with boot-repair I have the same error. I've tried installing Ubuntu 14.04 LTS with the same result. Investigating a little I've seen that if I try to mount sda1, this partition is always read only. Is this normal? Any idea on how can I complete my dual boot? This is the paste bin from boot-repair:

http://paste2.org/gCPyJFvg

By the way, I've turned off the fast boot in Windows 10.

  • In simple words, cl-netbox is telling you to put GRUB (Ubuntu's bootloader) "in front" (meaning in the root of your internal disk) of Windows bootloader, so that GRUB would recognize both Ubuntu and Windows, and to offer you the possibility of booting either one. And he's obviously right! You need to do that because Windows bootloader doesn't (and probably never will) recognize other OS than Windows. – ipse lute May 27 '16 at 10:55
  • We have seen corrupted ESP - efi system partitions. You can try chkdsk from Windows or sudo dosfsck -t -a -w /dev/sda1 from Ubuntu. In a few cases has to mount read only ro, back up everything, remove partition, recreate partition as FAT32, with boot flag to make it an ESP and restore data. Back up of ESP is always a good idea as that often is not included in most backups. – oldfred May 27 '16 at 13:48
2

First make sure that hibernation is disabled - so boot into Windows, open command prompt as administrator and execute : powercfg /h off. Shutdown the PC completely - do NOT reboot.

Then install GRUB boot loader to your Ubuntu installation in EFI mode.
Boot from the Ubuntu installation media, open a terminal and execute:

sudo mount /dev/sda8 /mnt
sudo mount /dev/sda1 /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
sudo chroot /mnt
grub-install /dev/sda
update-grub  

Note : sda = disk | sda1 = efi partition | sda8 = system partition | (taken from 'paste2' output)

Boot into BIOS - change the boot order in UEFI settings - select Ubuntu to be the default system.

|improve this answer|||||
  • hi @cl-netbox, solved with your instructions. Thanks!! Just two more questions. 1- What was the actual problem? (do I have to change the subject of the question for better future googling?) 2- In the left lauch bar I have an icon to "Install release". What is that? Do I have a "debug" version? Is it just the normal installer? – pblanco May 27 '16 at 16:15
  • @pblanco : You're welcome ... I am glad that your problem is solved. The main problem was that Windows was in hibernation mode, so the efi partition was in use and the Ubuntu installer could not write the boot files to it. As I do not know which Ubuntu version you have chosen I can't tell you what you have installed, but there does not exist any "debug version" and such an icon "Install release" I have never seen ... in case that you meant "Install Ubuntu" ... maybe you accidentally booted from the installation media again ... :) – cl-netbox May 28 '16 at 8:41
  • I installed Ubuntu 16.04. It's very strange. In any case, I'll ignore this icon (it looks like the normal installer). Thanks again. – pblanco May 30 '16 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.