1

I recently tried to install Ubuntu GNOME 16.04 on a separate partition on a newly built machine. It already has Windows 10 installed in BIOS Support Mode. I made a LiveUSB and tried to run the installer in legacy mode but it continually craps out on me (black screen with a cursor), so instead I tried running it in UEFI mode. I know that when dual booting it is best to keep the boot modes the same, but I could not get the Ubuntu installer to run in Legacy mode and I figure I can switch between OSes by setting the CSM settings in my motherboard's BIOS whenever I need to.

The problem comes up when I get to the actual installation phase of the bootloader. After downloading updated files and beginning the setup, I got following error

GRUB installation failed

The grub-efi-amd64-signed package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot." Does this possibly have to do with the fact that I already have an OS installed into BIOS mode? Is there a way to run the installation in Legacy mode without getting a black screen?

Please help me; I am at my wit's end. I have tried everything that the forum Q&A's have suggested and still I cannot get my system to boot properly. If there is anyone on here with experience dual booting Linux, feel free to offer your advice. I am an novice in Linux and have not typically had experience with matters of dual booting.

Thanks in advance.

Specs: Intel i7-6770K, Nvidia GTX 980 Ti

Also, it should be noted that I get an unknown chipset nouveau error whenever I launch the bootloader. I have yet to see an Ubuntu desktop so I wouldn't be surprised if there was a persistent driver problem I have yet to rectify.

  • Once you try this: Take a live ubuntu, and run it in live mode and type::sudo grub-install /dev/sda and then type: sudo update-grub. – Looserof7 May 27 '16 at 5:06
  • Did you make a (primary?) EFI partition to install the bootloaders (grub/shim)? Better stick with legacy, and fix the video (NVIDIA) and cpu (Skylake, 67xx) problems, which you will have either way. – ubfan1 May 28 '16 at 4:12
1

UPDATE: Since my last post, I have successfully installed Ubuntu GNOME beside Windows 10 on my Dell laptop. For my sake, this confirms that there is nothing wrong with the ISO file or my method of creating a LiveUSB using UNetbootin. However, since Windows 10 was apparently installed in UEFI mode on the laptop, this does not help my mission to install it on my personal rig.

To elaborate on my aforementioned issue, when I attempt to boot from USB, I get two options in the BIOS: one that says "Sandisk UEFI" and one that is plain "Sandisk". Now, obviously, I recognize that selecting the UEFI option will boot me in UEFI mode, but since selecting the text-based Legacy mode invariably hangs on me, I see no other recourse (more on this later). In the UEFI installer, I can continue through the installation process by clicking next (though, selecting "Install Third Party Software" in the menus causes it to hang and crash) until I get to the final initialization phase. Here, when it gets to the part wherein it installs GRUB2, I get an error message saying "GRUB installation failed; The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot.". I can only take this to mean that if I already have an operating system installed in BIOS/Compatibility Support mode, I am unable to install a secondary operating system in UEFI mode. If someone would wish to explain this aspect of the process, I more than welcome it.

Next, when I boot from the plain "Sandisk" option in my boot menu, I am presented with a custom UNetbootin text-based bootloader thing instead of the customary GRUB2 menu. From there, I have all the normal options, and can select "Install Ubuntu" as one of the options. When I do, the installer appears maladjusted to my screen resolution and hangs as soon as I press the first "Continue" button.

If I select any other option than "Install Ubuntu", I get a black screen and my computer hangs. Selecting "Try Ubuntu" invokes this behavior, as well as "Check disk for defects".

I have tried making a LiveUSB of Boot Repair, and I can successfully get a desktop environment and launch the repair tool. Unfortunately, the OS cannot detect my wired Ethernet connection and cannot access the Internet, and so gives me an error message with something along the lines of "Cannot perform operation without Internet connectivity". I am not sure how I can proceed with this avenue and welcome suggestions.

To the poster above me, I thank you for your instructions for rectifying the NVIDIA driver issue, but since I can view a preliminary GUI environment when launching the bootloader, I believe the more pressing issue is first installing the OS and seeing a desktop environment before worrying about installing propriety drivers.

Again, I am still pursue potential solutions. Many sites have suggested I add something before the "quiet splash" in the BIOS bootloader but I have tried these to no avail. If it is indeed a driver issue, I would expect Ubuntu would have better support for popular graphics hardware to insure an easier installation method. If dual booting Ubuntu, one of the most popular distros out there, is this difficult on a desktop PC, I can't say I struggle to see why Linux has failed to gain substantial market share in the desktop space (no hate haha).

  • Lately, I have wondered if I should just try to reinstall Windows 10 in UEFI mode instead of Legacy mode. Could someone link me to/walk me through the process of doing this? Thanks in advance. – Conexn Jun 2 '16 at 5:25
0

I'm going to talk about the unknown chipset nouveau error first. nouveau is a set of open source drivers for nvidia. Back when I installed my ubuntu on a dual boot I was using a GTX 970 and I received the same error. The problem is that there are currently no open source drivers for your graphics card so Ubuntu is unable to display anything to your screen until you install nvidia proprietary drivers on your system. So what you've really got here is a two step problem, first you need to install Ubuntu, then you must install the nvidia proprietary drivers. I don't know anything about BIOS support mode but I can confirm that I have a successful dual boot of windows 10 and ubuntu 15.04 using UEFI on both. Here's what I would try for your system.

First turn off your computer and unplug the DVI cord from your graphics card and plug it directly into your motherboard. You may have to go into your BIOS and change the output of your motherboard to the internal graphics chip often times abbreviated IGX or IGFX, it should be under display options.

Now turn on your computer and try to install Ubuntu from the live as normal. Once that finishes you should be able to restart your computer and see the grub menu to select your OS. If you don't see this grub read then you can try one of two things which I will detail in step 1 and 2. If you do see grub and can load both OSes, skip to step 3.

  1. Try fixing grub using a boot repair live cd. It's been a while since I've used this but if my memory is correct you just click an icon that's on the desktop and it runs the boot repair program for you. If after this you can successfully launch both OSes then go to step 3.

  2. If step 1 failed for you it is probably a complication from the BIOS support mode but I honestly can't say for sure because I've never used the feature. If you can go without BIOS support mode I would suggest reinstalling windows in UEFI and then installing Ubuntu in UEFI, otherwise I have no idea how to help you.

  3. Now you need to install your graphics card. With the cord still plugged directly into your mother board launch Ubuntu and read this post from my blog about how to install dota 2 and there is a section for installing the graphics card. It can be found at jordancamp.net.

  4. Go back into BIOS and change your display settings back to your graphics card. Turn off your computer and plug the DVI cord back into your graphics card and you should be good to go.

  5. If you can see the grub screen but Ubuntu launches to a black screen you may have to disable the splash screen. If that's the case leave a comment and I can tell you how to do that

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.