8

I just installed Ubuntu 16.04 on a Gigabyte PC. Installation went without any issues. This OS is fantastic. I just have one problem, it freezes often usually while browsing the Internet.Can someone please steer me in the right direction?

marked as duplicate by David Foerster, karel, Eric Carvalho, Pilot6, Anwar Sep 8 '16 at 13:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4

Since it's a Gigabyte PC I presume it is Intel-based.
Look in the comment section for changing "intel_idle.max_cstate", in the following bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1503731.

Another bug report in kernel bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=109051.

You can have a go in installing a newer kernel version kernel, I read somewhere this might be fixed in newer kernel versions(4.5 and up), here is a guide: https://wiki.ubuntu.com/Kernel/MainlineBuilds.

Hope it helped.

Edit:
Open terminal, Ctrl + Alt + T
Use sudo nano /etc/default/grub to open grub configuration file.
Replace the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

with this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"

Press Ctrl + x then "Y" (for yes, to save, and press enter), then type sudo update-grub, enter password if needed and press enter.
After Grub updated restart and hope it worked.

I also recommend closing the PCs if they are not needed, as this solution will only extend the duration until they freeze.

  • Thank you so much for all the questions, comments and suggestions. I am using 8 Gigs of RAM. The Browser is Firefox and the Mouse stops moving entirely. By the way, I installed Ubuntu 16.04 on two new Gigabyte PCs , one with a SSD of 120 GB (ADATA), the other with a 240 GB SSD (Kingstone). They both freeze. The one with the 240 GB SSD about once every 24 hours. The one with the 120 GB SSD about once every 1-2 hours. Again, thank you for your answers. – Wilfredo Perez Jun 3 '16 at 1:28
  • Hello Wilfredo, try the edited solution and let me know if it improved your uptime. – adi Jun 7 '16 at 7:36
  • same problem here. let's test the solution – Morteza Rastgoo Jul 16 '16 at 5:39
  • Had same problem, tried the grub option, and also disabled Intel virtualization in the BIOS, and the system can now play video for hours without freeze. Now of course I don't know which of the two changes was most effective . . . (Intel Celeron J1900 Atom) – Roland Apr 22 '18 at 16:24
0

My problem seemed to be Nouveau graphics drivers. First i updated kernel from 4.4 to 4.7-RC4 but it didn't help. Then I changed the graphics drivers from Nouveau to nvidia-340 and the random crashes seems to be gone...

  1. System Settings -> Software & Updates -> Additional Drivers: Using NIVIA binary drirver - version 340.96 from nvidia-340 (open source)
  2. reboot

Not the answer you're looking for? Browse other questions tagged or ask your own question.