5

When I try to power off Ubuntu 16.04 LTS on my MSI GS60, the laptop will not shut down. Reboot works fine though. I have removed the quiet splash parameters for grub so I can see the output. When I try to power off the laptop, it gets to:

[ OK ] Reached target Shutdown
[ OK ] Reached target Final Step.
Starting Power-Off...
reboot: Power down

and it stays like that forever. I have tried the Sys Req key trick to make it poweroff and it doesn't work.

I have tried to set the following in /etc/default/grub and then run update-grub

  • acpi=off --> won't even boot
  • noapic --> will shut down, but keyboard doesn't work at all
  • nolapic --> no difference
  • apm=power_off --> no difference
  • reboot=bios,force,efi,warm, etc... --> no difference
  • irqpoll --> no difference
  • acpi=force --> no difference
  • xhci quirks on grub config didn't help either

This known bug is a similar issue, but unrelated since in this case the system reaches the "halt" status but doesn't shutdown.

  • The known issue is not exactly the same as my problem. In my case, the whole system is halted once it gets to "Reached target shutdown". The Sys Req + REISUB does absolutely nothing at that point, so I would say it has something to do with the way Linux interacts with the BIOS/EFI. However, and as strange as it sounds, I found out that using systemd to change the execution state to level 0 will properly shut down the laptop, whereas sudo shutdown / sudo halt -p / ... will not – vagaerg May 31 '16 at 10:29
  • Same problem here on an MSI WS60. Initially we needed acpi=off to boot the USB stick. – Bram Jul 1 '16 at 9:18
2

I believe mine was a bit different because it was reaching the target [ OK ] Reached target Shutdown. I was forced to disable USB 3.0 in BIOS and now I can shut down normally.

  • Mine was reaching it too ;) It is still random, it will sometimes shut down and sometimes it will do nothing. The USB thing is strange, there are a few compatibility fixes for USB 3.0, but they didn't do anything in my case, and disabling USB 3 is not really an option for me. Thanks for the suggestion though, can be useful for future reference! – vagaerg Aug 21 '16 at 19:46
0

I had to upgrade my kernel to 4.7 RC3 for my Ubuntu 16.04 to shut down correctly, without hanging. Worth a shot for any other poor souls out there...Steps to upgrade kernel here: http://www.yourownlinux.com/2016/06/how-to-install-linux-kernel-4-7-rc3-in-linux.html

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.