I'm running Ubuntu 16.04 on an Dell XPS 13 9350 (skylake)

Since the old kernel doesn't support the broadcom wireless card I updated to ubuntu 16.04, coming from 15.10. The 4.4 kernel should support the card. But it still doesn't work.

EDIT: It seems that only starting from the 4.4.1-1 kernel the broadcom wireless card is supported (see Arch Wiki).

So, iwconfig shows the card. Also lspci shows it.

If I type sudo ip link set mywlan up ubuntu activates the card, but somehow recognizes it as an ethernet card. If I click the network Icon on the top right it says "Ethernet Network (Broadcom BCM4350 802.11ac Wireless Network Adapter)". And of course I don't get a connection to any wireless network. So... Any hints on how to change that? Any Ideas?


this question is related to No Wireless on Ubuntu 15.10 with Broadcom 4350 Card

EDIT: Output of lspci -knn | grep Net -A2:

3a:00.0 Network controller [0280]: Broadcom Corporation BCM4350 802.11ac Wireless Network Adapter [14e4:43a3] (rev 08)
    Subsystem: Dell BCM4350 802.11ac Wireless Network Adapter [1028:0021]
    Kernel driver in use: brcmfmac
    Kernel modules: brcmfmac

Looks like the right driver is in use...

File properties of brcmfmac4350-pcie.bin:

freebe@ubun:~$ ls -al /lib/firmware/brcm/brcmfmac4350-pcie.bin
-rw-r--r-- 1 root root 626140 Mär 21 13:27 /lib/firmware/brcm/brcmfmac4350-pcie.bin

EDIT (summary): So even with the 4.4.1 kernel ubuntu sometimes recognizes the card as a wifi-card, but most of the time as an ethernet card. For me it actually only recognized the card as a wifi-card once(!), this was at the first boot. This is probably a bug. If anyone has a reliable way to solve this issue I would be very thankful!

  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 May 27 '16 at 7:45
  • has been done :) – freebe May 27 '16 at 18:32
  • Does /lib/firmware/brcm/brcmfmac4350-pcie.bin exist in your system? – Pilot6 May 27 '16 at 18:39
  • Yes it, does exist, I added the file properties to the Main post – freebe May 27 '16 at 21:31

Okay, this was very simple. I should have read the Question I already linked to in the main post more thoroughly!

I just went to http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.1-wily/ downloaded the kernel image for 64bit systems (.deb-file) and installed it by double-clicking (Ubuntu Software Center). WiFi works now! :))

Thats it... Mui simple, very simple

EDIT: No, not that simple... see main thread -.-

|improve this answer|||||

For me it almost always works with 4.4.0-12-generic, for all the more recent kernel versions it only occasionally works but most of the time the wireless adapter is recognized as an ethernet card and does not work.

|improve this answer|||||
  • Which repositories do I have to add into /etc/apt/sources.list to get this kernel version? I'm currently using 4.4.0-22 – freebe May 30 '16 at 18:00
  • It's just there from left from the first beta version of 16.04 that I tried, with apt autoremove it would be removed. I don't know how to install an outdated package. Would be curios if things works with a mainline newer kernel. I recently tried yakkety with 4.5 kernel and it worked there (but it might just have been chance as I booted only once). – Reto Gmür May 30 '16 at 20:22
  • According to the arch.wiki link it works starting from kernel 4.4.1-1. Thats probably also the kernel I used when I was using Arch. Which brings me to the next question: How do I install a different kernel in general? – freebe May 30 '16 at 21:55
  • It doesn't seem to work even with the latest 4.6 RC. I've created bugzilla.kernel.org/show_bug.cgi?id=119321 – Reto Gmür May 31 '16 at 10:01
  • Yeah, seems like a bug. Although I doubt it is a kernel related bug, because it worked fine when I was using Arch Linux... Anyway, thanks for filing it! – freebe May 31 '16 at 22:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.