1

I have installed a Ubuntu Server 16.04 amd64 on my machine. I'm having trouble with ram capacity - first I installed a 2GB stick which free -m reported as 1430 total size, now I installed a different 4GB stick which is now reported as 3380 in size, see below:

x@x-server:~$ free -m
              total        used        free      shared  buff/cache   available
Mem:           3381         890        2022          14         468        2435
Swap:          1467           0        1467

It is a considerable amount of missing memory (~20%) - what could be the cause of this?

I'm using an ASUS AM1M-A board.

Both sticks have been used in other machines and are functioning properly.

  • 1
    That board uses a Integrated AMD Radeon APU with up to 2048MB of shared memory. Maybe the memory is allocated before the system gets a hold of it, and it's currently allocating 768MB? – user508889 May 26 '16 at 16:39
  • 1
    See also dr-lex.be/info-stuff/bytecalc.html – Panther May 26 '16 at 16:42
  • @bodhi.zazen you maybe should make an answer based on the information on that site. At least for the sake of having a right answer to up vote on it. You can link it as the source of the information provided. – Videonauth May 26 '16 at 16:51
  • @Videonauth - Not sure if that is the problem or not. If so -> convert to answer. If not .... – Panther May 26 '16 at 17:12
  • Nevertheless useful information :) – Videonauth May 26 '16 at 17:21
5

So your board doesn't have an onboard graphics, but it is an AM1 socket motherboard with builtin hdmi and dvi. Socket AM1 is intended for a class of CPUs that contain both an integrated GPU and a chipset, essentially forming a complete SoC implementation.

This leads me to believe that the missing RAM is being dedicated for the graphics processor (VRAM). There should be an option in the BIOS to change the allocated amount.

  • That makes sense and is most probably the cause. Unfortunately for me I was unable to find any settings in BIOS that would allow me to lower integrated graphics memory allowance or disable it at all, the only options were "auto" and "force". I guess I would have to sacrifice about 600 MB of RAM or install a dummy video card. – php_nub_qq May 26 '16 at 20:41
  • @php_nub_qq - If it makes you feel any better, my secondary desktop does the same thing. – You'reAGitForNotUsingGit May 28 '16 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.