14

I just installed Ubuntu 16.04 and let VMware Workstation 12 install it using the easy installation process. The minute I boot up the VM, I try and share folders using the VM settings window, and the first thing I get is:

Unable to update run-time folder sharing status: There was an error mounting the Shared Folders file system inside the guest operating system.

So here I am starting to troubleshooting after a fresh install of Ubuntu 16.04 running on my Windows 10 Pro host. The window auto-resize works just fine, I just can't share folders and that's pretty imoprtant for me.

Can someone please point me in the right direction here? Here's a few suggestions that I've read around online and tried without any success:

Suggestion #1

# http://askubuntu.com/a/290528/269349
sudo apt-get install linux-source
sudo apt-get install open-vm-tools
mount -t vmhgfs .host:/ /home/user1/shares

Didn't work, as I already have open-vm-tools installed and running the mount command just gives me an error stating Error: cannot mount filesystem: No such device

Suggestion #2

# https://github.com/vmware/open-vm-tools/issues/62#issuecomment-174631126
git clone https://github.com/vmware/open-vm-tools.git
cd open-vm-tools/open-vm-tools
sudo apt-get install libmspack0 libmspack-dev libprocps3 libprocps3-dev dnet-progs libdumbnet-dev doxygen
./configure --without-x --without-pam --without-ssl --without-icu
make MODULES=vmhgfs
insmod modules/linux/vmhgfs/vmhgfs.ko

mount -t vmhgfs .host:/ /mnt
ls /mnt

This doesn't work because then I get this error:

# sudo apt-get install libmspack0 libmspack-dev libprocps3 libprocps3-dev dnet-progs libdumbnet-dev doxygen
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libprocps3-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libprocps4-dev:i386 libprocps4-dev

E: Unable to locate package libprocps3
E: Package 'libprocps3-dev' has no installation candidate

Suggestion #3

Tried uninstalling open-vm-tools and installing VMware tools from the menu, but despite running sudo apt-get remove open-vm-tools && sudo apt-get autoremove, VMware Tools repeatedly tells me that open-vm-tools is still installed. Rebooting doesn't help either and I've tried researching how to complete uninstall open-vm-tools without any real solutions.

  • Why not use KVM or similar? – Panther May 26 '16 at 16:22
  • To replace VMware Tools and open-vm-tools? Never heard of it – user3447014 May 26 '16 at 16:36
  • linux.com/learn/create-and-run-virtual-machines-virt-manager Tons of tools for KVM from virt manager to web interfaces to whole OS with KVM - proxmox.com/en/proxmox-ve – Panther May 26 '16 at 16:39
  • 1
    Sorry, but I'm confused as to how this is relevant. This looks like an alternative to VMware and not necessarily how to simply fix VMware's shared folder issues that I'm experiencing. Am I missing something? – user3447014 May 26 '16 at 16:44
  • 1
    Contact VMWare for support on their closed source binary blob or convert to open source . – Panther May 26 '16 at 17:07
23

I had the same problem but I solved it by removing open-vm-tools and installing open-vm-tools-desktop and after a Reboot everything works.

  • Thanks for the suggestion!! gonna have to try that next time for sure – user3447014 May 28 '16 at 9:10
  • this worked for me on multiple occasions. – aholt Jun 17 '16 at 20:30
  • This worked for me, but only after nuking my install after trying various other things. – jtpereyda Jul 14 '16 at 17:51
  • 5
    To be a little more explicit, open Terminal and run sudo apt-get remove open-vm-tools then run sudo apt-get install open-vm-tools-desktop and reboot your VM. This worked for me on Ubuntu 16.04.1 x64 on VMWare Fusion 8.5.1 – romellem Nov 1 '16 at 18:13
  • 1
    I just installed open-vm-tools-desktop without removing open-vm-tools and it worked. – Ben May 2 '17 at 15:59
4

After wasting much time on this question the answer is:

  1. The easy install of 16.04.1 gives you the Ubuntu supplied open-vm-tools
  2. vmhgfs is replaced by vmhgfs-fuse
  3. You can install a mount in /etc/fstab like this (XFER is your share name, uid and gid are your choice, and the mount point /vmshare/xfer must exist, and is your choice:

    .host:/XFER /vmshare/xfer fuse.vmhgfs-fuse allow_other,uid=1000,gid=1000,auto_unmount,umask=0133 0 0

Use "vmhgfs-fuse --help" to see the options.

3

I have made open VM tools working on Ubuntu 16.04 like this:

  1. Uninstall open-vm-tools, open-vm-tools-desktop
    • sudo apt-get remove --purge open-vm-tools-desktop
    • sudo apt-get remove --purge open-vm-tools
  2. uninstall VMware tools.
    • First, mount disk with VMware tools tar file: Menu VM->reinstall VMware tools
    • Next, untar the installation file (VMwareTools-10.0.6-3595377.tar.gz) somewhere
    • Go to the un-tared folder /bin and run:
    • sudo ./vmware-uninstall-tools.pl
  3. Reboot the VM.
  4. Install open-vm-tools, open-vm-tools-desktop
    • sudo apt-get install open-vm-tools
    • sudo apt-get install open-vm-tools-desktop
  5. Reboot the VM and enjoy!
0

Not sure if I'd call this "the answer", but I basically reinstalled Ubuntu manually without letting VMware use the easy-install process (which apparently installs the broken open-vm-tools for you). After I finally booted up, I installed VMware Tools from the VM's menu and that worked flawlessly. Apparently open-vm-tools is what my problem was.

0

After an update to 16 from 14 the tools weren't allowing me multi screen or cut/paste etc from the host. I tried all of the above suggestions but the only thing that seemed to work for me was running: /usr/bin/vmware-user-suid-wrapper (and had to run it on subsequent boots, time to add it to boot script I think)

Strange but this seems to be a really old bug: https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/772837

hope this helps someone! Mark.

0

Master456's Answer works fine, I just wanted to add another answer to highlight an issue:

If you previously had vmware tools installed and are upgrading to open-vm-tools, after uninstalling vmware tools, you should also delete the /etc/vmware-tools (OR /etc/vmware) folder after uninstalling. Otherwise, you'll likely encounter an error like:

The VMware Tools power-on script did not run successfully in this virtual machine. If you have configured a custom power-on script in this virtual machine, make sure that it contains no errors. You can also submit a support request to report this issue.

Another side note: open-vm-tools and open-vm-tools-desktop run fine side-by-side, there is no need to uninstall open-vm-tools.

-1

Solution that works for me (VMware 12.1.1 build-3770994):

  1. sudo apt-get install linux-headers-$(uname -r) make gcc
  2. reinstall VMwareTools from VMware menu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.