0

When I set Windows as the first boot option in BIOS it boots into Windows normally, and the same goes for Linux. However when I set Ubuntu as the first option and try to choose Windows from boot menu but it won't boot. I tried boot repair but it didn't help. What should I do now?

2
  • 1
    Can you clarify what you mean by "it won't boot" - what error message do you see ? Commented May 26, 2016 at 15:00
  • 1
    Are both installed in BIOS boot or both installed in UEFI boot mode? If Ubuntu in BIOS and Windows in UEFI, you get the type of issue you seem to have. Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info
    – oldfred
    Commented May 26, 2016 at 16:31

2 Answers 2

0

Did you try updating the GRUB file?

Run the following:

  • sudo os-prober (type man os-prober to see what it does, see here for more info);
  • sudo grub-update (update the GRUB: you should see in the output both Ubuntu's and Windows' boot partitions);
  • sudo grub-install /dev/sda/ (Assuming your grub is installed at /dev/sda: change it accordingly)

Hope this helps!

4
  • Yes. I've done that. I think that real problem is with windows boot manager. As soon as I installed Ubuntu (pick an option to install along windows), I was unable to boot into windows wia standard boot menu.
    – alenphp
    Commented May 27, 2016 at 13:30
  • Hmm, how odd... I have had issues with Windows not being able to boot from Ubuntu's GRUB, but not like that. I suggest, if you can, you try fixing Window's boot partition. Once fixed, boot in Ubuntu using a live CD/DVD/USB and try to update the GRUB again. If Windows is not detected, then it is very likely an issue with Windows' boot partition. Here is a link that I use as a reference for repairing Windows' boot partition. Check out steps 4 and 5. Commented May 27, 2016 at 15:38
  • Were you able to fix your issue with another solution? Commented May 30, 2016 at 15:56
  • I've reinstalled everything so it's not an issue anymore.
    – alenphp
    Commented May 31, 2016 at 7:26
0

In UEFI boot options only recognizes the windows boot. You need to allow non-UEFI boot on BIOS and then select the partition that has the GRUB option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .