0

Having a tough time here. I have installed kernel 4.6 for my machine and using gcc 6.1.1 - so vmware workstation 12 installs fine but will not run. Does not find compatible gcc version 5.3.1

So wondering if anyone has a way to get this to work with gcc 6.1.1 or how to install 5.3.1 just for Vmware?

Thanks,

SJ

0

I got the same issue and found a solution. But I never consider about my gcc version. This solution works fine on kernel 4.6.x. Need to change some c codes. Actually this solution for fedora but works well on Ubuntu 16.04 kernel 4.6.x.x.

  1. find following archives on /usr/lib/vmware/modules/source

    • vmmon.tar
    • vmnet.tar

Before make any changes backup original archives.

  1. untar vmmon.rar and find /vmmon-only/linux/hostif.c file and change "get_user_pages" to "get_user_pages_remote"
  2. tar and replace original
  3. untar vmnet.tar and find /vmnet-only/userif.c file and change "get_user_pages" to "get_user_pages_remote"
  4. tar and replace original

then start vmware workstation.

source : https://bugzilla.redhat.com/show_bug.cgi?id=1278896

  • Thanks I did try that but still not working. After that I run sudo vmware-modconfig --console --install-all. But I still get "failed to get gcc information" – scopa Jun 7 '16 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.