7

enter image description here

Here is an example above. It also does the same thing on other sites with other video players, but I figure this is one of the more well known ones.

Any help?

3
  • What version of Ubuntu, and what version of opera?
    – Mateo
    May 26 '16 at 1:19
  • Ubuntu 14.04.4 LTS and Opera 39.0.2234.0
    – Carson
    May 26 '16 at 1:25
  • The support at opera forums is really good. I recommend going there. forums.opera.com May 26 '16 at 1:52
2

Run this command in a terminal (Ctrl+Alt+T):

sudo apt-get install chromium-codecs-ffmpeg-extra

Then restart Opera.

2

As others have stated, the main problem is ffmpeg library. To fix that, install Chromium and then copy the ffmpeg.so file that Chromium uses. You can do it like this:

sudo cp /snap/chromium/current/usr/lib/chromium-browser/libffmepg.so /usr/lib/x86-64-linux-gnu/opera/

After that, just restart Opera and the problem will be fixed.

NOTE: Everytime Opera upgrades, you need to copy ffmpeg.so.

0
1

If you are having trouble with videos on the web that are not flash, it is probably a video that uses the H.264 codec. In the past chromium-codecs-ffmpeg-extra has resolved this (and might again) Unfortunately, Opera has some issues with using the library sometimes, because it's so tightly integrated with chromium. There is no 100% good solution of getting H.264 support in Opera right now.

Basically Opera is having trouble with the licensing. The library that provides many codecs that Opera uses is called ffmpeg. However, they have removed the H.264 part of it, because even though ffmpeg has a free license, the patent pool of H.264 will demand license fees from commercial projects that are using implementations of it, like Opera.

Chromium and Chrome, however, do have support for H.264 in their ffmpeg library, because Google has payed the license fee.

Switching to Google Chrome or perhaps Chromium is highly likely to resolve this issue entirely.(it did for me on both Ubuntu 14.04 and 16.04 - 64-bit)

The only other option I can suggest even trying is the installation of the Ubuntu Resticted Extras Package Available in the [multiverse repository] which is defined as Unsupported, Closed-Source and Patent-Encumbered Software:

For more on the multiverse repository and how and whether to enable it see this excellent Q & A

Sources:

https://help.ubuntu.com/community/OperaBrowser

What's the difference between multiverse, universe, restricted and main?

0

I installed skype for linux then copied skypes libffmpeg.so to opera with the following command. sudo cp /usr/share/skypeforlinux/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so Restart Opera. Videos now play on Opera.

-1

I'm using Linux Mint cinammon 20.0 and Opera 71. I tried copying the libffmpeg.so from Chromium, but as I didm't install it y found another in whatsapp. I opened /usr/lib as root. Foud the opera libffmpeg.so (about 1.8 MB) and renamed it as libffmpeg-opera.so as a safety measure. Then copied libffmpeg.so from whatsapp (about 3.2MB) and pasted into opera. Reinitiated Opera and problem solved.

1
  • Hey JP Sanchez! Your answer is not clear to me. What do you mean by from WhatsApp? Sep 23 '20 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.