I upgraded to Ubuntu 16.04 lately and reinstalled texlive and texmaker to write in latex. When testing it for a new document I saw that the pdf was not being displayed properly. To clarify the document was shrinked in the vertical direction. When switching to the default ubuntu Document Viewer the pdf was displayed normally which leads me to believe that the document compiles properly (pdfLatex) but the viewer does not display it properly. I didn't have this problem in Ubuntu 14.04 and uninstalling and reinstalling - after reboot - texmaker didn't do anything either.

Any suggestions?


From the research I 've done trying to fix the problem it appears that the upgrade from qt4 to qt5 (which is used to build the package if I get it right) is not working that well. There is a bug report in Ubuntu website about it. (This is what's called regression right?). So I uninstalled again (with dpkg -P) [got some unity executable crash reports from ubuntu for some reason, after every boot]. Then I went to texmaker website and downloaded version 4.5 for Ubuntu 14.04. It needed to install qt4 as dependency and then installed properly. It even made the reboot error go away.

As for texmaker pdf's are displaying properly now. Even shortcuts are working - they weren't working as well but hadn't put that here.

TLDR: Uninstall and install texmaker version that uses qt4 to build because the newer one isn't working properly.


I ran into the same problem upgrading from 14.04 to 16.04, running in vmplayer7. Here are the steps I took.

You can download a Texmaker package suitable for your Ubuntu release and architecture from its manufacturer. To install it you need to

  1. Remove existing Texmaker packages from your system:

    sudo apt-get remove texmaker texmaker-data
  2. Follow How do I install a .deb file via the command line? to install the downloaded .deb file.

  • Ubuntu 15.10 reached EOL a while ago and became off topic here. But you can replace that part of the URL with 12.04, 14.04, or 16.04` according to your needs. – David Foerster Aug 5 '16 at 18:00
  • I had already tried that. At that time downloading an older version from the manufacturers page is what did it for me (as I say in my answer). Now hoewever with subsequent qt5-related package updates or texmaker updates the issue may be solved and the latest version may work. – Karsus Aug 5 '16 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.