4

I have read that Eclipse Neon has now support for hidpi but icons are extremely small when using a hidpi notebook in Ubuntu 16.04.

Is there any command line argument or environment variable that I have to set so it works?

7

At least in my case (ASUS UX303UB, Eclipse Neon 4.6.0RC1, Ubuntu 16.04), it was possible to get proper icons by adding:

-Dswt.autoScale=175

at the end of $ECLIPSE_HOME/eclipse.ini

  • This indeed helped (with neon.3), but when I needed the scale back at 100% changing the mentioned parameter to 100 didn't help. Nor did adding -Dswt.enable.autoScale=false. Any suggestions? – tlwhitec May 18 '17 at 12:33
  • OK, I figured it out. It was the automatically created ~/.local/share/applications/eclipse.desktop after I pinned the running upscaled eclipse to the Unity launcher. It contained all the eclipse.ini parameters in the Exec= action. Changing this just to eclipse or running eclipse from the command line normally worked. – tlwhitec May 18 '17 at 12:54
0
-Dswt.autoScale=exact

worked for me. It apparently used my Gnome Tweak Tool font scaling setting of 1.35 The autoScale options are explained at Tweaking SWT's auto-scaling

0

For me the following worked:

GDK_DPI_SCALE=0.5 GDK_SCALE=2 eclipse

Setting GDK_SCALE to 2 alone fixed the icon size but made all text huge. I had to set GDK_DPI_SCALE to 0.5 counter the effect on the font size.

0

If you want to create a launcher, use the following in the command editor (adapted from Zoltan):

env GDK_DPI_SCALE=0.4 env GDK_SCALE=2 eclipse

I'm using it on a 4k 15.6' display.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.