5

I have a dual Intel 6th gen./AMD Radeon HD graphics, and I have recently upgraded to Ubuntu 16.04 LTS. I was prviously on Ubuntu 14.04, using Intel graphics driver in Ubuntu 16.04, installed from here:

https://download.01.org/gfx/ubuntu/14.04/

Video acceleration worked just fine in VLC in 14.04. But, now I have several issues with video acceleration, including the inability to scale the video. So, I want to use graphics drivers provided by Intel, but unfortuanately there is no prebuilt packages for 16.04 in 01.org repositories. What should I do?

Another issue is that I no longer see propertiary drivers in "additional drivers" section of the "software and updates" utility. Is it because I am using newer kernels? Previously I could be able to see AMD propertiary drivers, and install it if I wanted, which I once did for testing, and then returned to Intel graphics.

PS: In the list provided here, I have a Gen6 Intel GPU. I have installed the 15.04 binaries, and this is the output from vainfo:

$ vainfo 
libva info: VA-API version 0.39.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.39 (libva 1.7.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Sandybridge Mobile - 1.7.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc

PS2: The problems with VAAPI support on Intel drivers seem to be widespread. For example, see these:

https://github.com/mpv-player/mpv/issues/941

https://steamcommunity.com/groups/homestream/discussions/1/616199736997712785/

  • 1
    Possible duplicate of How do I install the Intel Graphics driver in my system? – dobey May 25 '16 at 13:29
  • 1
    As for AMD GPU: no support of proprietary driver in 16.04 (at least at the moment) – Sergey Sergeyev May 25 '16 at 13:30
  • 1
    @dobey I didn't say that I was using propertiary drivers for Intel graphics, I just said that I was using the drivers provided by Intel. And it is not a duplicate, because the mentioned question is old, and is not concerned with 16.04. If you know how can I find the code for the latest drivers to compile and install, please help. – Ho1 May 25 '16 at 13:44
  • 1
    @dobey No, chip doesn't support VAAPI, but the driver/libraries do or do not. Chip provides the acceleration for certain codecs. Intel® HD Graphics is VAAPI compatibe, and provides the acceleration for the codes I use including H.264: 01.org/linuxgraphics/community/vaapi I've added the output from vainfo command. – Ho1 May 25 '16 at 13:54
  • 1
    Somewhat related to this matter: omgubuntu.co.uk/2016/03/… Meaning you can currently only use the drivers provided by 16.04. – DrA7 May 25 '16 at 14:02
5

Update 30 Aug, 2016: Latest drivers from Intel are now available

Default installation Ubuntu 16.04 should work somehow fine. Intel drivers are included in the default installation of Ubuntu 16.04 with Linux 4.2 kernel, and you the hardware acceleration works in VLC if you choose "XCB" output. But this is not the latest drivers from Intel. Here we read:

  • u16.04 already contains the latest intel driver that has passed full QA
  • There is no point in installing the u15.10 updates on u16.04 - even if you succeeded it would be a downgrade

Recent update:

Recently, Intel released Intel Graphics Update Tool 2.0.2 which supports Ubuntu 16.04. Download it from here:

https://01.org/linuxgraphics/downloads/intel-graphics-update-tool-linux-os-v2.0.2

Intel Graphics Update Tool

2

I had the same problem. I have solved it by install intel driver like below (i think it's a part of the solution ;-) ) AND chose the GLX video output in VLC setting.

  • I'm currently using the same output, but does XCB output use hardware acceleration? – Ho1 May 28 '16 at 4:23
1

I temporarily replaced the contents of /etc/lsb-release with:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.10
DISTRIB_CODENAME=wily
DISTRIB_DESCRIPTION="Ubuntu 15.10"

In this way "Graphics Installer 1.4.0 for Ubuntu* 15.10, 32-bit" was installed.

Before reboot I restored the original contents of /etc/lsb-release. Drivers work fine.

  • Thanks for the answer. Could you be able to play a video with VLC with hardware acceleration enabled? – Ho1 May 27 '16 at 11:29
  • 1
    Yep. I tried run 2K video in VLN with hardware acceleration, works fine. – ComBin May 27 '16 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.