0

I have installed Ubuntu 16.04 and and there is no sign of wi-fi, no on/off indicator

I have seen all the solutions on internet: enter image description here how to handle wi-fi problems, but none worked for me. I have HP Pavillion laptop.

What can I do?

output: arjun@arjun-HP-Pavilion-15-Notebook-PC:~$ lspci -vvnn | grep -A 9 Network

0

8:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    DeviceName: Broadcom BCM43142 802.11bgn 1x1 WiFi Adapter + BT 4.0 combo adapter
    Subsystem: Hewlett-Packard Company BCM43142 802.11b/g/n [103c:2230]
    Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Interrupt: pin A routed to IRQ 0
    Region 0: Memory at b5500000 (64-bit, non-prefetchable) [size=32K]
    Capabilities: <access denied>
    Kernel modules: bcma, wl

marked as duplicate by Eric Carvalho, karel, WinEunuuchs2Unix, Kevin Bowen, Zanna Nov 24 '16 at 21:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • may you disable network manager from startup application – Mohamed Slama May 25 '16 at 12:13
  • @MohamedSlama there is no option for disabling network manager.. – Arjun Gupta May 25 '16 at 12:20
  • i.stack.imgur.com/612ya.png – Arjun Gupta May 25 '16 at 12:28
  • 2
    The image clearly shows Airplane Mode is on. That suggests that the wireless switch or key combination on the laptop is set to disable wireless. Please find it and switch it. – chili555 May 25 '16 at 13:34
  • 1
    Please run the ubuntu forums wireless script (github.com/UbuntuForums/wireless-info) and paste the results into paste.ubuntu.com then edit your question to include a link to it – Steve Roome May 25 '16 at 19:29
0
sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms linux-firmware

this worked on ubuntu 14.06. test it and tell me if it worked for 16.04 too.

-2

I had faced the same issue in HP Pavillion laptop twice. Follow these steps:

  1. Run sudo apt-get update && sudo apt-get upgrade

  2. Download bcmwl-kernel-source in .deb format and then install through terminal. It may ask additional dependency, Download and install them separately.

-2

It looks like the kernal can detect your hardware but lacks the driver software to make it work, so what you need to do is install the drivers for your wireless card. I searched broadcom's website but I couldn't find the drivers for your wireless card but I found another driver that is similar enough that it might work for you. I'm not sure of your linux experience so I will just describe the whole process of installing it.

Download the file in the link open up a terminal and type these commands

cd ~/Downloads
tar -xzvf name_of_file_goes_here
make
sudo make install
  • it says=> make: *** No rule to make target 'install'. Stop. – Arjun Gupta May 27 '16 at 23:36
  • arjun@arjun-HP-Pavilion-15-Notebook-PC:~/Downloads/src$ make make: *** No targets specified and no makefile found. Stop. – Arjun Gupta May 27 '16 at 23:37
  • My mistake, you don't need to cd source because the Makefile is one directory higher than that. So skip the cd source and just do make then sudo make install. I will edit my answer to reflect these changes. – Jordan Camp May 28 '16 at 1:56
  • now it gives output as=> install -D -m 755 wl.ko /lib/modules/uname -r/kernel/drivers/net/wireless – Arjun Gupta May 29 '16 at 9:04
  • what should i do now?? – Arjun Gupta May 29 '16 at 9:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.