5

I just did a fresh installation of Lubuntu 16.04, 64-bit on this computer.

Before Lubuntu even loads, I get this message:

/dev/sda6: clean, 121539/6234222 files, 1053787/24914550 blocks

How can I make Lubuntu proceed with the boot?

Additional information:

  • There are three other partitions. One has Windows XP, one has Windows 7 and one is swap for Lubuntu.
  • I've previously run Ubuntu 14.04 32-bit on the same computer without encountering this issue. It was then a dual boot with Windows XP. I have since formatted the whole drive.
  • At present, recovery mode works.
  • I get the same message wtih xubuntu and ubuntu-mate 16.04 but after a while it just starts (I think this message is just a check up for your disk which ubuntu does since 15.04 if I remember correctly). Are you sure you just don't wait enought time? – Thanos Apostolou May 25 '16 at 9:56
  • 1
    Yeah the message is on every boot but it doesn't take more than 30 secs to boot. Try login on one tty with ctrl+alt+F1 and run 'sudo service lightdm restart'. – Thanos Apostolou May 25 '16 at 10:00
  • @ThanosApostolou When I try to ctrl+alt+F 1, the login flashes for half a second, and then the message from OP comes back. – Revetahw May 25 '16 at 10:02
  • 1
    Better wait for someone else to answer but you can try setting nomodeset as described here and see if that helps (just try from the grub menu don't edit the grub file): askubuntu.com/questions/38780/…. – Thanos Apostolou May 25 '16 at 10:12
  • @ThanosApostolou It booted :) You can post that as an answer, I will accept and upvote :) – Revetahw May 25 '16 at 10:19
2

Thanos' answer will get you into a low graphics mode which is a first step to solving this problem completely.

The problem is in the ancient Intel graphics cards which aren't recognized by the kernel. So to fix it you need to do this:

Intel Graphic 945 driver for ubuntu 12.04 lts

now your computer should be working in it's full resolution. If it still fails to boot into a graphical environment, add i945.modeset=0 to the GRUB boot command as shown here:

https://community.linuxmint.com/tutorial/view/842

It solved my problems on MSI Wind u100 (which has similar specs to yours Eee PC)

  • Yes, this makes sense! This explains what happened. The screen resolution was very low, and I could hardly play any video with a size larger then 400*300. Only now do I realise why that happened. I won't be able to test your solution, because I've already wiped the computer and installed Xubuntu 16.04 instead. Xubuntu didn't have the same problem, and the graphics are working fine on Xubuntu without any tinkering at all. – Revetahw Jun 2 '16 at 20:25
  • That's a bit strange, by the way. Don't Xubuntu and Lubuntu use the same kernel? – Revetahw Jun 2 '16 at 20:30
4

Well, the complete answer is that:

  1. Add temporarily the nomodeset boot option (from the grub boot menu without editing the /etc/default/grub file yet) as described here: How do I set 'nomodeset' after I've already installed Ubuntu?

  2. After you login try run the commands sudo apt-get update and sudo apt-get dist-upgrade and reboot (the nomodeset option was just temporary) and see if it was a bug which got fixed with the update (you could also run this from the rocovery mode before trying nomodeset).

  3. I it wasn't fixed you can try again with nomodeset option and after you login go to Software & Updates and under the Additional Drivers tab see if there is any proprietary gpu driver and install it. (also intel-microcode is good to have if it's available but has nothing to do with this problem). It is important to remember which package it installs (if it isn't obvious from the name then google it) in order to be able to remove it from recovery mode if your system doesn't boot afterwards. Reboot to see if it got fixed. If it doesn't work then remove it.

  4. If step 2 and 3 doesn't work then set nomodeset at /etc/default/grub file as described at the first link to make it permanent. Don't forget to run sudo update-grub afterwards.

  • Awesome. I edited the grub file to make it permanent, it works fine. I didn't wanna update at the moment, because I'm on a limited internet connection. Anyway, Lubuntu boots, I'm happy, thanks. – Revetahw May 25 '16 at 10:39
  • :D Glad i could help :D – Thanos Apostolou May 25 '16 at 10:40
-1

Encountered similar symptoms while trying to install 32-bit lubuntu on an Asus EEE 1000HE. After 3 install attempts, I gave-up on lbuntu 16.04. Important: it would would not boot lubuntu properly from the compact-flash. I was able to install with Ubuntu 16.04, so I concluded the hardware was not the problem. Finally, I tried lubuntu 15.10 and it installed: it was able to boot lubuntu from the 15.10 flash. I think that if it can not boot from the flash, an install will be unsuccessful.

  • Sounds similar. I ended up installing Xubuntu 16.04, which worked fine. I guess I like XFCE better, anyway. – Revetahw Jul 2 '16 at 18:15
-1

Solution for this problem :

When you stuck at :

/dev/sda6: clean, 121539/6234222 files, 1053787/24914550 blocks

DO :

  1. (Open System Terminal ALT+F6 AND LOGIN)

  2. Change Line GRUB_CMDLINE_LINUX_DEFAULT ON /etc/default/grub TO GRUB_CMDLINE_LINUX_DEFAULT=""

  3. Reboot System and should be fine

this solution works with the nomodeset of grub

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.