Jumping cursor while typing on my Asus EEE PC 1015PE. Keyboard shortcut--Function key plus F3 also not working, as well as a few other function keys not working. Would appreciate any help. Note: mouse/touchpad "Disable touchpad while typing" setting is enabled, but does not work.

  • perennial problem on my mba, bookmarked – prusswan Jul 30 '13 at 2:43
gksudo gedit /etc/modprobe.d/options.conf

Add this line to the file and save it:

options psmouse proto=imps


Source: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/355326/comments/9

  • I created the above file with the "options psmouse proto=imps" and the touchpad settings completely disappeared from the Mouse/Touchpad system settings. Now only mouse settings remain. The – MHPathfinder Nov 10 '11 at 4:52
  • 1
    I removed the options.conf. Restarted. It feels like the problem is gone. No more jumping cursor and the touchpad settings returned to the Mouse/Touchpad system settings app. Hypothesis: It could have been a faulty touchpad driver installation, which was removed with the creation of the options.conf file. When I removed the file, the touchpad driver reinstalled, probably correctly. So, indirectly, the above instructions led to a true fix, which was actually an initially faulty touchpad driver configuration, now corrected. Thanks for the help for the solution. MH – MHPathfinder Nov 10 '11 at 5:07
  • A dirty solution, but it is still a solution :) – heartsmagic Nov 10 '11 at 8:01

Try disabling mouse/touchpad "Disable touchpad while typing" setting and maybe it will help with that couse anyway u say it doesnt work so maybe thats why it jumps couse doesnt work. Also try again enabling. and restart after each try.

If doesnt help leave as disabled that option and install Touchfreeze from ubuntu soft manager. If on reboot it doesnt work automatically then put it to be starting on startup in System > Preferences > Sessions startup programms with adding new and writing command in there touchfreeze

  • Cursor still jumps after applying above "fix which also made all of the touchpad settings disappear from the Mouse/Touchpad system settings app. so, I can't attempt the second "fix" as touchpad options are gone. My search for fix continues. – MHPathfinder Nov 10 '11 at 4:56

I had the same issue, solution was to install SYNAPTIKS from the Ubuntu 11.10 repo. Worked well, no-more issues.


Try using the FN key and the f buttons, obviously not those marked for general use like brightness or sound.

I just found that if I use the fn and f5 buttons on my laptop it stops the touchpad. I had tried various other things to deactivate it, from unistalling to diabling to downloading software; then came across this post and yeahhhh it works like magic. :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.